aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-13 10:33:36 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:43 +0000
commita59917ea8fd86b35f3ccd6179a0f67be5767712a (patch)
tree7aed7ce2483d68cddc14b413e62ad8d0af785e85 /gnu/packages/golang.scm
parent3da934f279b06bb3c2429d65152d2cd250df023b (diff)
downloadguix-a59917ea8fd86b35f3ccd6179a0f67be5767712a.tar.gz
guix-a59917ea8fd86b35f3ccd6179a0f67be5767712a.zip
gnu: gopls: Update to 0.16.2.
* gnu/packages/golang.scm (gopls): Update to 0.16.2. [native-inputs]: Remove go-github-com-jba-printsrc, go-github-com-sergi-go-diff, go-golang-org-x-sys, and go-golang-org-x-tools; add go-golang-org-x-telemetry. Change-Id: Ia21d8816796d424c6dc83441469385eaa24f6031
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm13
1 files changed, 6 insertions, 7 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index ceaca67cc0..8257f571b4 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -3112,16 +3112,16 @@ command-line parsers.")
(name "gopls")
;; XXX: Starting from 0.14.0 gppls needs golang.org/x/telemetry, which
;; needs to be discussed if it may be included in Guix.
- (version "0.13.2")
+ (version "0.16.2")
(source
(origin
(method git-fetch)
(uri (git-reference
(url "https://go.googlesource.com/tools")
- (commit (string-append "gopls/v" version))))
+ (commit (go-version->git-ref version #:subdir "gopls"))))
(file-name (git-file-name name version))
(sha256
- (base32 "1qym2c0xvv6vcgwh0kz8sw094r88lzrl08xpvmg08lrqi00ma6kx"))))
+ (base32 "1l6mkh4v0f602spw3zdmkxqizk32zvgpfy461sinqwhlag8v8v3a"))))
(build-system go-build-system)
(arguments
(list
@@ -3132,17 +3132,16 @@ command-line parsers.")
#~(modify-phases %standard-phases
(add-before 'unpack 'override-tools
(lambda _
+ ;; XXX: Write a procedure deleting all but current module source
+ ;; to cover case with monorepo.
(delete-file-recursively "src/golang.org/x/tools"))))))
(native-inputs
(list go-github-com-google-go-cmp
- go-github-com-jba-printsrc
go-github-com-jba-templatecheck
- go-github-com-sergi-go-diff
go-golang-org-x-mod
go-golang-org-x-sync
- go-golang-org-x-sys
+ go-golang-org-x-telemetry
go-golang-org-x-text
- go-golang-org-x-tools
go-golang-org-x-vuln
go-gopkg-in-yaml-v3
go-honnef-co-go-tools