aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang.scm
diff options
context:
space:
mode:
authorPierre Neidhardt <mail@ambrevar.xyz>2018-10-24 11:43:17 +0200
committerPierre Neidhardt <mail@ambrevar.xyz>2018-10-24 12:13:49 +0200
commit27d59d8bf5ed9a6560f15951395d03f05dc8d645 (patch)
tree28720776d51914d415231df8ef77eb55603d3415 /gnu/packages/golang.scm
parent15272a5053f4c70c073713febfbba3c4623f82de (diff)
downloadguix-27d59d8bf5ed9a6560f15951395d03f05dc8d645.tar.gz
guix-27d59d8bf5ed9a6560f15951395d03f05dc8d645.zip
gnu: Add go-github-com-gxed-hashland-keccakpg.
* gnu/packages/golang.scm (go-github-com-gxed-hashland-keccakpg): New variable.
Diffstat (limited to 'gnu/packages/golang.scm')
-rw-r--r--gnu/packages/golang.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 795ab29838..87a1cd625e 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -2789,3 +2789,29 @@ Architecture Processors\" by J. Guilford et al.")
trivial @command{big.Int} encoding benchmark results in 6 times faster
encoding and 8 times faster decoding.")
(license license:expat))))
+
+(define-public go-github-com-gxed-hashland-keccakpg
+ (let ((commit "d9f6b97f8db22dd1e090fd0bbbe98f09cc7dd0a8")
+ (revision "0"))
+ (package
+ (name "go-github-com-gxed-hashland-keccakpg")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gxed/hashland.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1q23y4lacsz46k9gmgfw4iwwydw36j2601rbidmmswl94grpc386"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:unpack-path "github.com/gxed/hashland"
+ #:import-path "github.com/gxed/hashland/keccakpg"))
+ (home-page "https://github.com/gxed/hashland")
+ (synopsis "Implements the Keccak (SHA-3) hash algorithm in Go")
+ (description "Package @command{keccak} implements the Keccak (SHA-3)
+hash algorithm. See http://keccak.noekeon.org.")
+ (license license:expat))))
>Ludovic Courtès 2019-05-01nls: Update manual translations for de, es, fr, and zh_CN.Ludovic Courtès 2019-04-30build: 'guix-manual.*.po' no longer depends on 'guix-manual.pot'....Ludovic Courtès 2019-04-30nls: Remove 'guix-manual.pot'....Ludovic Courtès 2019-04-29maint: Mark 'doc-pot-update' and 'doc-po-update' as phony....Ludovic Courtès 2019-04-27nls: Fix wrong include name....Clément Lassieur 2019-04-27nls: Update 'zh_CN' translation....Julien Lepiller 2019-04-25nls: Update 'es' translation.Julien Lepiller 2019-04-25nls: Update 'de' translation.Julien Lepiller 2019-04-25nls: Update 'fr' translation.Julien Lepiller 2019-04-24nls: Update 'fr' translation of the manual.Julien Lepiller 2019-04-24doc: Add Simplified Chinese translation....Ludovic Courtès 2019-04-24nls: Fix guix-manual.zh_CN.po....Ludovic Courtès 2019-04-24doc: Add zh_CN PO file....Ludovic Courtès 2019-04-23doc: Add Spanish translation....Miguel Ángel Arruga Vivas 2019-04-17nls: Update 'de' translation of the manual.Ludovic Courtès 2019-04-02nls: Update 'de' translation of the manual.Ludovic Courtès 2019-03-12nls: Update 'de' translation of the manual.Julien Lepiller 2019-03-01nls: Update 'fr' translation of the manual.Julien Lepiller 2019-01-28nls: Update 'de' translation of the manual.Ludovic Courtès