aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-27 10:04:58 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-27 10:07:01 +0100
commitb4b875d4a0ae02f5f1ba2b3b96d76ccfe31b5340 (patch)
tree00d9dcdb1fc41ca2f18a9194d0ecdc6830b36e76 /gnu/packages/golang-xyz.scm
parent0b00161f90d99c890e9f333267addd33a68a2077 (diff)
downloadguix-b4b875d4a0ae02f5f1ba2b3b96d76ccfe31b5340.tar.gz
guix-b4b875d4a0ae02f5f1ba2b3b96d76ccfe31b5340.zip
gnu: Add go-github-com-avast-retry-go-v3.
* gnu/packages/golang-xyz.scm (go-github-com-avast-retry-go-v3): New variable. Change-Id: I90857cf75765ec4c39141d462444fe3d775968a9
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 4358569d53..fe2ea055de 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -857,6 +857,35 @@ for functions that may fail. It includes various customizable retry
strategies, such as fixed delay, backoff delay, and random delay.")
(license license:expat)))
+(define-public go-github-com-avast-retry-go-v3
+ (package
+ (inherit go-github-com-avast-retry-go)
+ (name "go-github-com-avast-retry-go-v3")
+ (version "3.1.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/avast/retry-go")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "01mwrzjh2y3xignkivx8kaghjs3gwb3z89zqgxjfaslslazc863b"))))
+ (arguments
+ (list
+ #:import-path "github.com/avast/retry-go/v3"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-failing-tests
+ (lambda* (#:key tests? import-path #:allow-other-keys)
+ (with-directory-excursion (string-append "src/" import-path)
+ (substitute* (find-files "." "\\_test.go$")
+ (("TestMaxDelay") "OffTestMaxDelay")))))
+ (add-after 'unpack 'remove-examples
+ (lambda* (#:key import-path #:allow-other-keys)
+ (delete-file-recursively
+ (string-append "src/" import-path "/examples")))))))))
+
(define-public go-github-com-aymanbagabas-go-osc52-v2
(package
(name "go-github-com-aymanbagabas-go-osc52-v2")