aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-07-27 09:59:34 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-07-27 10:00:59 +0100
commit0b00161f90d99c890e9f333267addd33a68a2077 (patch)
treed0afd82889f6cbeb9307c07a8af9b8d1ce595b34 /gnu/packages/golang-xyz.scm
parentb97196b9443024355065ed1db7f9e1d52e006aa3 (diff)
downloadguix-0b00161f90d99c890e9f333267addd33a68a2077.tar.gz
guix-0b00161f90d99c890e9f333267addd33a68a2077.zip
gnu: go-github-com-avast-retry-go: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-avast-retry-go): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: Ie6d53537689aea9454e9fc07958d162f323b1f2a
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 00c89761e3..4358569d53 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -825,6 +825,38 @@ for generating command line clients for your application configuration that is
stored in a Go struct.")
(license license:mpl2.0)))
+(define-public go-github-com-avast-retry-go
+ (package
+ (name "go-github-com-avast-retry-go")
+ (version "2.7.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/avast/retry-go")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0zkn8c2gyz8j90bf0aj6avfl3sf7j4rk5g4ak4yhglnsx72jdhbz"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/avast/retry-go"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'remove-examples
+ (lambda* (#:key import-path #:allow-other-keys)
+ (delete-file-recursively
+ (string-append "src/" import-path "/examples")))))))
+ (propagated-inputs (list go-github-com-stretchr-testify))
+ (home-page "https://github.com/avast/retry-go")
+ (synopsis "Simple golang library for retry mechanism")
+ (description
+ "This package is a simple Go library that provides retry functionality
+for functions that may fail. It includes various customizable retry
+strategies, such as fixed delay, backoff delay, and random delay.")
+ (license license:expat)))
+
(define-public go-github-com-aymanbagabas-go-osc52-v2
(package
(name "go-github-com-aymanbagabas-go-osc52-v2")