aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-29 16:52:52 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-29 16:52:52 +0100
commita2ca087a85470aed7b5bb2f90b57daf0b89ca151 (patch)
tree3bc5a1e1150e5c359ab8b47b1f99543e0dc48e3c /gnu/packages/golang-xyz.scm
parent088d174fd99335cb516f7cddd2d2d240fd8fa7ce (diff)
downloadguix-a2ca087a85470aed7b5bb2f90b57daf0b89ca151.tar.gz
guix-a2ca087a85470aed7b5bb2f90b57daf0b89ca151.zip
gnu: go-github-com-matttproud-golang-protobuf-extensions-pbutil: Rename variable.
* gnu/packages/golang-xyz.scm (go-github-com-matttproud-golang-protobuf-extensions-pbutil): Rename variable to go-github-com-matttproud-golang-protobuf-extensions-v2 as seen in go.mod. [arguments]: <#:unpack-path>: Remove it. <#:import-path>: Swap to "github.com/matttproud/golang_protobuf_extensions/v2". <#:phases>: Add custom 'check phase. Remove 'build phase. * gnu/packages/golang.scm (go-github-com-prometheus-common) [propagated-inputs]: Remove go-github-com-matttproud-golang-protobuf-extensions-pbutil. Add go-github-com-matttproud-golang-protobuf-extensions-v2. Change-Id: Icf9db2997a47be4f0babec10edcb01a578a7a7e7
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm17
1 files changed, 13 insertions, 4 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 118fe4f558..dafa4b2904 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -2702,9 +2702,9 @@ the @code{cpan} module @code{Parse::CommandLine}.")
other directories. It is optimized for filewalking.")
(license license:expat)))
-(define-public go-github-com-matttproud-golang-protobuf-extensions-pbutil
+(define-public go-github-com-matttproud-golang-protobuf-extensions-v2
(package
- (name "go-github-com-matttproud-golang-protobuf-extensions-pbutil")
+ (name "go-github-com-matttproud-golang-protobuf-extensions-v2")
(version "2.0.0")
(source
(origin
@@ -2720,8 +2720,17 @@ other directories. It is optimized for filewalking.")
(build-system go-build-system)
(arguments
(list
- #:import-path "github.com/matttproud/golang_protobuf_extensions/v2/pbutil"
- #:unpack-path "github.com/matttproud/golang_protobuf_extensions/v2"))
+ #:import-path "github.com/matttproud/golang_protobuf_extensions/v2"
+ #:phases
+ #~(modify-phases %standard-phases
+ ;; XXX: Activate when go-build-system supports submodules.
+ (delete 'build)
+ ;; XXX: Replace when go-build-system supports nested path.
+ (replace 'check
+ (lambda* (#:key import-path tests? #:allow-other-keys)
+ (when tests?
+ (with-directory-excursion (string-append "src/" import-path)
+ (invoke "go" "test" "-v" "./..."))))))))
(propagated-inputs
(list go-github-com-golang-protobuf
go-google-golang-org-protobuf))