aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-xyz.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-06-29 16:45:27 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-06-29 16:45:27 +0100
commit088d174fd99335cb516f7cddd2d2d240fd8fa7ce (patch)
treee05888feb1db210a3b96a597ddacc36f5a4aa908 /gnu/packages/golang-xyz.scm
parent34c5573728ebc24f702d915cdacc6c67155713e4 (diff)
downloadguix-088d174fd99335cb516f7cddd2d2d240fd8fa7ce.tar.gz
guix-088d174fd99335cb516f7cddd2d2d240fd8fa7ce.zip
gnu: go-github-com-matttproud-golang-protobuf-extensions-pbutil: Move to golang-xyz.
* gnu/packages/syncthing.scm (go-github-com-matttproud-golang-protobuf-extensions-pbutil): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: I7681af021b51e7c349a48cc5bd7822dbb78c6a1b
Diffstat (limited to 'gnu/packages/golang-xyz.scm')
-rw-r--r--gnu/packages/golang-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 189a39b6fe..118fe4f558 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -2702,6 +2702,36 @@ the @code{cpan} module @code{Parse::CommandLine}.")
other directories. It is optimized for filewalking.")
(license license:expat)))
+(define-public go-github-com-matttproud-golang-protobuf-extensions-pbutil
+ (package
+ (name "go-github-com-matttproud-golang-protobuf-extensions-pbutil")
+ (version "2.0.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/matttproud/golang_protobuf_extensions")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0jw4vjycwx0a82yvixmp25805krdyqd960y8lnyggllb6br0vh41"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/matttproud/golang_protobuf_extensions/v2/pbutil"
+ #:unpack-path "github.com/matttproud/golang_protobuf_extensions/v2"))
+ (propagated-inputs
+ (list go-github-com-golang-protobuf
+ go-google-golang-org-protobuf))
+ (home-page "https://github.com/matttproud/golang_protobuf_extensions")
+ (synopsis "Streaming Protocol Buffers in Go")
+ (description
+ "This package provides various Protocol Buffer extensions for the Go
+language, namely support for record length-delimited message streaming.")
+ (license license:asl2.0)))
+
(define-public go-github-com-mgutz-ansi
(let ((commit "9520e82c474b0a04dd04f8a40959027271bab992")
(revision "0"))