aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorLeo Nikkilä <hello@lnikki.la>2024-08-24 16:36:16 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-25 20:46:47 +0100
commita2a8a7ec7061250171759bb8bdfcdb62a6661e10 (patch)
tree3e6f0994a496fa0010d99a7fdbe2a0ab801e7709 /gnu/packages/golang-web.scm
parent750fcdad2842ae3be18e37ea61c184f1612d5618 (diff)
downloadguix-a2a8a7ec7061250171759bb8bdfcdb62a6661e10.tar.gz
guix-a2a8a7ec7061250171759bb8bdfcdb62a6661e10.zip
gnu: Add go-github-com-go-openapi-swag.
* gnu/packages/golang-web.scm (go-github-com-go-openapi-swag): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: Id6258a11cdb8e1c04de0dc155ecef157ec74df83
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index d12bc14b67..c30a4dff34 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1371,6 +1371,34 @@ language.")
found in the go-openapi toolkit.")
(license license:asl2.0)))
+(define-public go-github-com-go-openapi-swag
+ (package
+ (name "go-github-com-go-openapi-swag")
+ (version "0.23.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/go-openapi/swag")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1c03mnmy162rrd1rzfqxiwnblvlwl4v09yklq55q4j9p4jqv740g"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/go-openapi/swag"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (propagated-inputs
+ (list go-github-com-mailru-easyjson go-gopkg-in-yaml-v3))
+ (home-page "https://github.com/go-openapi/swag")
+ (synopsis "Goodie bag in use in the go-openapi projects")
+ (description
+ "Contains a bunch of helper functions for go-openapi and go-swagger
+projects.")
+ (license license:asl2.0)))
+
(define-public go-github-com-go-webauthn-webauthn
(package
(name "go-github-com-go-webauthn-webauthn")