aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-web.scm
diff options
context:
space:
mode:
authorLeo Nikkilä <hello@lnikki.la>2024-08-24 16:30:42 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-25 20:46:47 +0100
commit750fcdad2842ae3be18e37ea61c184f1612d5618 (patch)
treeb61bd6047925f1724c4890d6159730c0c71f4dfb /gnu/packages/golang-web.scm
parent90efc854994c0d9d0dc1123350061060614b4d7c (diff)
downloadguix-750fcdad2842ae3be18e37ea61c184f1612d5618.tar.gz
guix-750fcdad2842ae3be18e37ea61c184f1612d5618.zip
gnu: Add go-github-com-go-openapi-errors.
* gnu/packages/golang-web.scm (go-github-com-go-openapi-errors): New variable. Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com> Change-Id: I3676121428a741124a6a15ef0855de48c882ff4a
Diffstat (limited to 'gnu/packages/golang-web.scm')
-rw-r--r--gnu/packages/golang-web.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang-web.scm b/gnu/packages/golang-web.scm
index fbdef8a35f..d12bc14b67 100644
--- a/gnu/packages/golang-web.scm
+++ b/gnu/packages/golang-web.scm
@@ -1345,6 +1345,32 @@ Encryption, JSON Web Signature, and JSON Web Token standards.")
language.")
(license license:expat)))
+(define-public go-github-com-go-openapi-errors
+ (package
+ (name "go-github-com-go-openapi-errors")
+ (version "0.22.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/go-openapi/errors")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0nikzvknkv0nqdy44dfi096lcvkjnpjfrpg1gqlkg5ffccvdnd9s"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/go-openapi/errors"))
+ (native-inputs
+ (list go-github-com-stretchr-testify))
+ (home-page "https://github.com/go-openapi/errors")
+ (synopsis "OpenAPI toolkit common errors")
+ (description
+ "Shared errors and error interface used throughout the various libraries
+found in the go-openapi toolkit.")
+ (license license:asl2.0)))
+
(define-public go-github-com-go-webauthn-webauthn
(package
(name "go-github-com-go-webauthn-webauthn")