aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-crypto.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-01-16 22:31:35 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-28 23:21:03 +0000
commit91c79f376aad4edb4accc21b99e420a629ad9616 (patch)
tree5c2686fcc668eabd43edf9cafe2af0c55c86bd62 /gnu/packages/golang-crypto.scm
parent547eec541d3c1258a1d0a63b76e2f554715b6acd (diff)
downloadguix-91c79f376aad4edb4accc21b99e420a629ad9616.tar.gz
guix-91c79f376aad4edb4accc21b99e420a629ad9616.zip
gnu: go-github-com-riobard-go-bloom: Move to (gnu packages golang-crypto).
* gnu/packages/golang.scm (go-github-com-riobard-go-bloom): Move from here ... * gnu/packages/golang-crypto.go: ... to here. Change-Id: I5ec63d8d9d90690348f494cb538ec2c4587a7557
Diffstat (limited to 'gnu/packages/golang-crypto.scm')
-rw-r--r--gnu/packages/golang-crypto.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index 96e12a1194..da331ceb3b 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -67,6 +68,29 @@
(description "Multihash implementation in Go.")
(license license:expat))))
+(define-public go-github-com-riobard-go-bloom
+ (let ((commit "cdc8013cb5b3eb0efebec85f0e904efccac42df9")
+ (revision "0"))
+ (package
+ (name "go-github-com-riobard-go-bloom")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/riobard/go-bloom")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "10a8ixh6zw52df2imxrzgxi82zc1j5hqnv5smjp818qwdn1a1rhj"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/riobard/go-bloom"))
+ (home-page "https://github.com/riobard/go-bloom")
+ (synopsis "Bloom filter in Go")
+ (description "Go-Bloom implements bloom filter using double hashing.")
+ (license license:asl2.0))))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar