aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/golang-crypto.scm24
-rw-r--r--gnu/packages/golang.scm24
2 files changed, 24 insertions, 24 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index 96e12a1194..da331ceb3b 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
+;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -67,6 +68,29 @@
(description "Multihash implementation in Go.")
(license license:expat))))
+(define-public go-github-com-riobard-go-bloom
+ (let ((commit "cdc8013cb5b3eb0efebec85f0e904efccac42df9")
+ (revision "0"))
+ (package
+ (name "go-github-com-riobard-go-bloom")
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/riobard/go-bloom")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "10a8ixh6zw52df2imxrzgxi82zc1j5hqnv5smjp818qwdn1a1rhj"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/riobard/go-bloom"))
+ (home-page "https://github.com/riobard/go-bloom")
+ (synopsis "Bloom filter in Go")
+ (description "Go-Bloom implements bloom filter using double hashing.")
+ (license license:asl2.0))))
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 2042a03ef6..a0983a20d3 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1859,30 +1859,6 @@ configuration file.")
"Golang utilities to make your life easier with zero allocations.")
(license license:asl2.0))))
-(define-public go-github-com-riobard-go-bloom
- (let ((commit "cdc8013cb5b3eb0efebec85f0e904efccac42df9")
- (revision "0"))
- (package
- (name "go-github-com-riobard-go-bloom")
- (version (git-version "0.0.0" revision commit))
- (source
- (origin
- (method git-fetch)
- (uri
- (git-reference
- (url "https://github.com/riobard/go-bloom")
- (commit commit)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "10a8ixh6zw52df2imxrzgxi82zc1j5hqnv5smjp818qwdn1a1rhj"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/riobard/go-bloom"))
- (home-page "https://github.com/riobard/go-bloom")
- (synopsis "Bloom filter in Go")
- (description "Go-Bloom implements bloom filter using double hashing.")
- (license license:asl2.0))))
-
(define-public go-github-com-aead-chacha20
(let ((commit "8b13a72661dae6e9e5dea04f344f0dc95ea29547")
(revision "0"))