aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-crypto.scm
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-11-14 23:05:08 +0300
committerArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-11-22 19:00:28 +0300
commit78ba54d9465d61eb372555dfe7607f18a6a2cbd4 (patch)
treede3c0755a1acf905a6eb2b8cfca5538bcbad73dd /gnu/packages/golang-crypto.scm
parentf0adac0ecf15195f319cc7b09057d869c23ddf36 (diff)
downloadguix-78ba54d9465d61eb372555dfe7607f18a6a2cbd4.tar.gz
guix-78ba54d9465d61eb372555dfe7607f18a6a2cbd4.zip
gnu: Add go-github-com-zeebo-blake3.
* gnu/packages/golang-crypto.scm (go-github-com-zeebo-blake3): New variable. Change-Id: I23bc863fb1731b520aeca8e9088a98c6fcfcf62d Reviewed-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/golang-crypto.scm')
-rw-r--r--gnu/packages/golang-crypto.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index 168eb73ac4..7fdc502de6 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -1727,6 +1727,35 @@ PKCS#8 PrivateKeyInfo format and EncryptedPrivateKeyInfo format with
PKCS#5 (v2.0) algorithms.")
(license license:expat)))
+(define-public go-github-com-zeebo-blake3
+ (package
+ (name "go-github-com-zeebo-blake3")
+ (version "0.2.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zeebo/blake3")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "117p973ccgalaqg7byj0qcd1xapysplql9np1sr9jkca500khcgf"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/zeebo/blake3"))
+ (native-inputs (list go-github-com-zeebo-assert))
+ (propagated-inputs
+ (list go-github-com-klauspost-cpuid-v2
+ go-github-com-zeebo-pcg))
+ (home-page "https://github.com/zeebo/blake3")
+ (synopsis "Pure Go implementation of BLAKE3")
+ (description
+ "@code{blake3} is an implementation of
+@url{https://en.wikipedia.org/wiki/BLAKE_(hash_function)#BLAKE3, BLAKE3} with AVX2
+and SSE4.1 acceleration.")
+ (license license:cc0)))
+
(define-public go-github-com-zeebo-pcg
(package
(name "go-github-com-zeebo-pcg")