aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/golang-crypto.scm
diff options
context:
space:
mode:
authorArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-11-14 22:59:22 +0300
committerArtyom V. Poptsov <poptsov.artyom@gmail.com>2024-11-22 19:00:22 +0300
commitf0adac0ecf15195f319cc7b09057d869c23ddf36 (patch)
tree2e6a175cffd3319611fdfb613e0ba9062bd10eae /gnu/packages/golang-crypto.scm
parent8398642ec371a8c68b8e42a1b263ccf5ca5e3351 (diff)
downloadguix-f0adac0ecf15195f319cc7b09057d869c23ddf36.tar.gz
guix-f0adac0ecf15195f319cc7b09057d869c23ddf36.zip
gnu: Add go-github-com-zeebo-pcg.
* gnu/packages/golang-crypto.scm (go-github-com-zeebo-pcg): New variable. Change-Id: Ic66e2221288fcd5e22196a12786d37150acec414 Reviewed-by: Sharlatan Hellseher <sharlatanus@gmail.com>
Diffstat (limited to 'gnu/packages/golang-crypto.scm')
-rw-r--r--gnu/packages/golang-crypto.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/golang-crypto.scm b/gnu/packages/golang-crypto.scm
index 1236ff38e3..168eb73ac4 100644
--- a/gnu/packages/golang-crypto.scm
+++ b/gnu/packages/golang-crypto.scm
@@ -1727,6 +1727,32 @@ PKCS#8 PrivateKeyInfo format and EncryptedPrivateKeyInfo format with
PKCS#5 (v2.0) algorithms.")
(license license:expat)))
+(define-public go-github-com-zeebo-pcg
+ (package
+ (name "go-github-com-zeebo-pcg")
+ (version "1.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/zeebo/pcg")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "02vyy2zc4jdcyf22dxw8dxcp1gwzy8j5qd6yxw324qyh2w557nh5"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/zeebo/pcg"))
+ (native-inputs (list go-github-com-zeebo-assert))
+ (home-page "https://github.com/zeebo/pcg")
+ (synopsis "PCG random number generator")
+ (description
+ "@code{pcg} is a random number generator that uses
+@url{https://en.wikipedia.org/wiki/Permuted_congruential_generator, Permuted
+Congruential Generator} (PCG) algorithm.")
+ (license license:cc0)))
+
(define-public go-lukechampine-com-blake3
(package
(name "go-lukechampine-com-blake3")