aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/diffoscope.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2023-01-25 09:41:43 +0200
committerEfraim Flashner <efraim@flashner.co.il>2023-01-25 09:45:30 +0200
commite71dc64e23853b069d861ed1deeeebecda1705e4 (patch)
tree9fe1dcef47cd579d1565a958e71861daedf1fbdf /gnu/packages/diffoscope.scm
parent718223c58c20fa066527fb30da2b5dccca82913f (diff)
downloadguix-e71dc64e23853b069d861ed1deeeebecda1705e4.tar.gz
guix-e71dc64e23853b069d861ed1deeeebecda1705e4.zip
gnu: diffoscope: Use newer llvm.
* gnu/packages/diffoscope.scm (diffoscope)[source]: Remove patch. [native-inputs]: Replace llvm-9 with llvm. * gnu/packages/patches/diffoscope-fix-llvm-test.patch: Remove file. * gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/diffoscope.scm')
-rw-r--r--gnu/packages/diffoscope.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/diffoscope.scm b/gnu/packages/diffoscope.scm
index cb8e9e01b9..4c88468c3c 100644
--- a/gnu/packages/diffoscope.scm
+++ b/gnu/packages/diffoscope.scm
@@ -5,7 +5,7 @@
;;; Copyright © 2018 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2018, 2019 Rutger Helling <rhelling@mykolab.com>
;;; Copyright © 2019 Vagrant Cascadian <vagrant@reproducible-builds.org>
-;;; Copyright © 2022 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2022, 2023 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -84,9 +84,7 @@
(commit version)))
(file-name (git-file-name name version))
(sha256
- (base32 "1m6fc7k8cd7ahra05vqccw1fdbjj6d20vr3q8v67ynnyih5nmbnb"))
- (patches
- (search-patches "diffoscope-fix-llvm-test.patch"))))
+ (base32 "1m6fc7k8cd7ahra05vqccw1fdbjj6d20vr3q8v67ynnyih5nmbnb"))))
(build-system python-build-system)
(arguments
`(#:phases (modify-phases %standard-phases
@@ -193,7 +191,7 @@
hdf5
imagemagick
libarchive
- llvm-9
+ llvm
lz4
lzip
ocaml