aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/crates-crypto.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-03-18 12:01:41 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-07-19 00:43:19 +0300
commit506bd05fbf34523c29394b00b9898f39140daa01 (patch)
tree3dbd940f15c137b2978a9abf3f931c73dd109e11 /gnu/packages/crates-crypto.scm
parentb419a47dd5d4b0e925da782b4efce17fb07a46fc (diff)
downloadguix-506bd05fbf34523c29394b00b9898f39140daa01.tar.gz
guix-506bd05fbf34523c29394b00b9898f39140daa01.zip
gnu: Add rust-ghash-0.4.
* gnu/packages/crates-crypto.scm (rust-ghash-0.4): New variable. Change-Id: Ia5399806c24db13d798138f47317bbc175555714
Diffstat (limited to 'gnu/packages/crates-crypto.scm')
-rw-r--r--gnu/packages/crates-crypto.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/crates-crypto.scm b/gnu/packages/crates-crypto.scm
index 23471ddaaf..7bef14b16d 100644
--- a/gnu/packages/crates-crypto.scm
+++ b/gnu/packages/crates-crypto.scm
@@ -2247,6 +2247,31 @@ for constructing a Message Authentication Code (MAC), as in the AES-GCM
authenticated encryption cipher.")
(license (list license:expat license:asl2.0))))
+(define-public rust-ghash-0.4
+ (package
+ (inherit rust-ghash-0.5)
+ (name "rust-ghash")
+ (version "0.4.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "ghash" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "169wvrc2k9lw776x3pmqp76kc0w5717wz01bfg9rz0ypaqbcr0qm"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin (substitute* "Cargo.toml"
+ (((string-append ">=([[:digit:]]+(\\.[[:digit:]]+)*),"
+ " <([[:digit:]]+(\\.[[:digit:]]+)*)")
+ _ version _)
+ (string-append ">=" version)))))))
+ (arguments
+ `(#:cargo-inputs (("rust-opaque-debug" ,rust-opaque-debug-0.3)
+ ("rust-polyval" ,rust-polyval-0.5)
+ ("rust-zeroize" ,rust-zeroize-1))
+ #:cargo-development-inputs (("rust-hex-literal" ,rust-hex-literal-0.3))))))
+
(define-public rust-ghash-0.3
(package
(inherit rust-ghash-0.5)