aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/crates-crypto.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2024-03-18 12:01:41 +0200
committerEfraim Flashner <efraim@flashner.co.il>2024-07-19 00:43:19 +0300
commitb419a47dd5d4b0e925da782b4efce17fb07a46fc (patch)
tree9684208b60e21487cd717c3f1a229ec133169468 /gnu/packages/crates-crypto.scm
parent5471f8ea2e58bc6819e3170ec0ba0c778b326bee (diff)
downloadguix-b419a47dd5d4b0e925da782b4efce17fb07a46fc.tar.gz
guix-b419a47dd5d4b0e925da782b4efce17fb07a46fc.zip
gnu: Add rust-polyval-0.5.
* gnu/packages/crates-crypto.scm (rust-polyval-0.5): New variable. Change-Id: If208731848ce91c5cdd18b7a6e03ed9707e3cf94
Diffstat (limited to 'gnu/packages/crates-crypto.scm')
-rw-r--r--gnu/packages/crates-crypto.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/crates-crypto.scm b/gnu/packages/crates-crypto.scm
index ad74f81479..23471ddaaf 100644
--- a/gnu/packages/crates-crypto.scm
+++ b/gnu/packages/crates-crypto.scm
@@ -3568,6 +3568,33 @@ a cipher, can be used as a Message Authentication Code (MAC).")
for constructing a Message Authentication Code (MAC).")
(license (list license:asl2.0 license:expat))))
+(define-public rust-polyval-0.5
+ (package
+ (inherit rust-polyval-0.6)
+ (name "rust-polyval")
+ (version "0.5.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "polyval" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1890wqvc0csc9y9k9k4gsbz91rgdnhn6xnfmy9pqkh674fvd46c4"))
+ (modules '((guix build utils)))
+ (snippet
+ '(begin (substitute* "Cargo.toml"
+ (((string-append ">=([[:digit:]]+(\\.[[:digit:]]+)*),"
+ " <([[:digit:]]+(\\.[[:digit:]]+)*)")
+ _ version _)
+ (string-append ">=" version)))))))
+ (arguments
+ `(#:cargo-inputs (("rust-cfg-if" ,rust-cfg-if-1)
+ ("rust-cpufeatures" ,rust-cpufeatures-0.2)
+ ("rust-opaque-debug" ,rust-opaque-debug-0.3)
+ ("rust-universal-hash" ,rust-universal-hash-0.4)
+ ("rust-zeroize" ,rust-zeroize-1))
+ #:cargo-development-inputs (("rust-hex-literal" ,rust-hex-literal-0.3))))))
+
(define-public rust-polyval-0.4
(package
(inherit rust-polyval-0.6)