aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-01-17 22:13:38 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-28 23:21:06 +0000
commit8882af2572de94b93cce3be6ebccf0bee51f8ee1 (patch)
tree63d402f448b5492065bc45c2276415014d539e03 /gnu/packages/check.scm
parent88fea61aaed0498ab81928933a3b4293a7656549 (diff)
downloadguix-8882af2572de94b93cce3be6ebccf0bee51f8ee1.tar.gz
guix-8882af2572de94b93cce3be6ebccf0bee51f8ee1.zip
gnu: go-github.com-smartystreets-assertions: Move to (gnu packages golang-check).
* gnu/packages/check.scm (go-github.com-smartystreets-assertions): Move from here ... * gnu/packages/golang-check.scm: ... to here. Change-Id: Ia90bbe984fe19dd48d9df91364a7ecf2bf8bd37f
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm33
1 files changed, 0 insertions, 33 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 7c6d8b967b..1f4c69cf99 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -898,39 +898,6 @@ prevent common NGINX misconfigurations. It provides the @command{gixy}
command.")
(license license:mpl2.0))))
-(define-public go-github.com-smartystreets-assertions
- (package
- (name "go-github.com-smartystreets-assertions")
- (version "1.13.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/smartystreets/assertions")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0flf3fb6fsw3bk1viva0fzrzw87djaj1mqvrx2gzg1ssn7xzfrzr"))))
- (build-system go-build-system)
- (arguments
- (list
- #:import-path "github.com/smartystreets/assertions"
- #:phases
- #~(modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key inputs #:allow-other-keys #:rest args)
- (unless
- ;; The tests fail when run with gccgo.
- (false-if-exception (search-input-file inputs "/bin/gccgo"))
- (apply (assoc-ref %standard-phases 'check) args)))))))
- (native-inputs
- (list go-github.com-smartystreets-gunit))
- (synopsis "Assertions for testing with Go")
- (description
- "The @code{assertions} package provides convenient assertion functions
-for writing tests in Go.")
- (home-page "https://github.com/smartystreets/assertions")
- (license license:expat)))
-
(define-public go-github.com-smartystreets-goconvey
(package
(name "go-github.com-smartystreets-goconvey")