aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/check.scm
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-01-17 22:08:20 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-01-28 23:21:06 +0000
commit88fea61aaed0498ab81928933a3b4293a7656549 (patch)
tree3eb3495ff9ec8f219f69eb9facb3cce25ce0692b /gnu/packages/check.scm
parent965f6d74acb591c8ab1efe23a737a52011ba885a (diff)
downloadguix-88fea61aaed0498ab81928933a3b4293a7656549.tar.gz
guix-88fea61aaed0498ab81928933a3b4293a7656549.zip
gnu: go-github.com-smartystreets-gunit: Move to (gnu packages golang-check).
* gnu/packages/check.scm (go-github.com-smartystreets-gunit): Move from here ... * gnu/packages/golang-check.scm: ... to here. Change-Id: I7204e118f99064027f0e10838d2b44fee212d21d
Diffstat (limited to 'gnu/packages/check.scm')
-rw-r--r--gnu/packages/check.scm30
1 files changed, 0 insertions, 30 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index a7ba16574f..7c6d8b967b 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -898,36 +898,6 @@ prevent common NGINX misconfigurations. It provides the @command{gixy}
command.")
(license license:mpl2.0))))
-(define-public go-github.com-smartystreets-gunit
- (package
- (name "go-github.com-smartystreets-gunit")
- (version "1.0.0")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/smartystreets/gunit")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "00m4zg0kdj49mnpmf9klb44ba71p966xsk6zknrzqgfc8119f35z"))))
- (build-system go-build-system)
- (arguments
- '(;; TODO: This package depends on go-github.com-smartystreets-assertions
- ;; for running the tests, but go-github.com-smartystreets-assertions
- ;; depends on this package, so break this loop by not running the tests
- ;; for this package.
- #:tests? #f
- #:import-path "github.com/smartystreets/gunit"))
- (synopsis "Testing tool for Go, in the style of xUnit")
- (description
- "@code{gunit} allows the test author to use a struct as the scope for a
-group of related test cases, in the style of xUnit fixtures. This makes
-extraction of setup/teardown behavior (as well as invoking the system under
-test) much simpler.")
- (home-page "https://github.com/smartystreets/gunit")
- (license license:expat)))
-
(define-public go-github.com-smartystreets-assertions
(package
(name "go-github.com-smartystreets-assertions")