aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Reichör <stefan@xsteve.at>2025-02-05 19:35:29 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2025-02-05 21:54:08 +0000
commitf89232b10d801933b0196cefb21a547bbec97efb (patch)
treeb5fbfa89741b7ba45308a6ef92e51688b95b9e72
parent9e378b7c4e1318fc6010be793ebd680c5e40576d (diff)
downloadguix-f89232b10d801933b0196cefb21a547bbec97efb.tar.gz
guix-f89232b10d801933b0196cefb21a547bbec97efb.zip
gnu: Add python-multiplex.
It was proposed in #48430 on <2021-05-14>. * gnu/packages/python-xyz.scm (python-multiplex): New variable. Change-Id: I75af1e4be940166b91c8c71dd0280cdb4753f956 Reviewed-by: Vinicius Monego <monego@posteo.net> Co-authored-by: Sharlatan Hellseher <sharlatanus@gmail.com> Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/python-xyz.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 63eff843ad..8dfa34e1d8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -578,6 +578,37 @@ comparison operators, as defined in the original
@url{http://goessner.net/articles/JsonPath/, JSONPath} proposal.")
(license license:asl2.0)))
+(define-public python-multiplex
+ (package
+ (name "python-multiplex")
+ (version "0.6.1")
+ (source
+ (origin
+ (method git-fetch) ;no tests in PyPI archive
+ (uri (git-reference
+ (url "https://github.com/dankilman/multiplex")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1a662liqhiya47i6vrz3q03w08viqg3wj5j3g58mz175hcdcmmmv"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-poetry-core
+ python-pytest
+ python-pytest-asyncio))
+ (propagated-inputs
+ (list python-aiofiles
+ python-aiostream
+ python-click
+ python-easy-ansi
+ python-pyte))
+ (home-page "https://github.com/dankilman/multiplex")
+ (synopsis "Parallel stream of outputs from multiple processes")
+ (description
+ "This package provides a functionality to view output of multiple
+processes, in parallel, in the console, with an interactive TUI.")
+ (license license:expat)))
+
(define-public python-pyxdameraulevenshtein
(package
(name "python-pyxdameraulevenshtein")