aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMekeor Melire <mekeor.melire@gmail.com>2025-02-05 21:14:43 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2025-02-05 21:54:08 +0000
commit9e378b7c4e1318fc6010be793ebd680c5e40576d (patch)
treee6930f6d6e764e6e4a740d8cc18f3f91491fd2bf
parent26b022deb98761016e6aaf539109d62ba47d8f5b (diff)
downloadguix-9e378b7c4e1318fc6010be793ebd680c5e40576d.tar.gz
guix-9e378b7c4e1318fc6010be793ebd680c5e40576d.zip
gnu: Add python-domain-connect-dyndns.
It was preoposed in #48514 on <2021-05-19>. * gnu/packages/python-web.scm (python-domain-connect-dyndns): New variable. Change-Id: I3a31379b4b4ed58c3503d6a8d5fd5a960702bec0 Reviewed-by: Xinglu Chen <public@yoctocell.xyz> Co-authored-by: Sharlatan Hellseher <sharlatanus@gmail.com> Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/python-web.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index bb31988d59..4f6287c0b6 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -357,6 +357,40 @@ caching server.")
Async mode for @url{https://domainconnect.org/, Domain Connect protocol}.")
(license license:expat)))
+(define-public python-domain-connect-dyndns
+ (package
+ (name "python-domain-connect-dyndns")
+ (version "0.0.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "domain-connect-dyndns" version))
+ (sha256
+ (base32 "0srrblcb64bp7k5cqqivx4kykqdkmmzmspxwv66vix9k7wxdwqzx"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ ;; Check and sanity-check phases require /etc/resolv.conf, which is not
+ ;; present in container.
+ #:tests? #f
+ #:phases #~(modify-phases %standard-phases (delete 'sanity-check))))
+ (native-inputs
+ (list python-setuptools
+ python-wheel))
+ (propagated-inputs
+ (list python-dnspython
+ python-domain-connect
+ python-requests
+ python-validators))
+ (home-page "https://github.com/Domain-Connect/DomainConnectDDNS-Python")
+ (synopsis "Domain Connect Dynamic DNS in Python")
+ ;; Project lacks meaningful description in README, see
+ ;; <https://github.com/Domain-Connect/DomainConnectDDNS-Python/issues/43>.
+ (description
+ "Python client library for Dynamic DNS using
+@url{https://www.domainconnect.org/, Domain Connect} protocol.")
+ (license license:expat)))
+
(define-public python-eventlet
(package
(name "python-eventlet")