aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-08-23 16:30:54 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-23 17:05:18 +0100
commited907c7a29b1bdc143d148cccf7e5d1967fcb50b (patch)
treedd6d19481075edf650cfcbbaf7fc61133d7b5c57
parente4391ff7e54eba3d99b2f4659f245149e39a270d (diff)
downloadguix-ed907c7a29b1bdc143d148cccf7e5d1967fcb50b.tar.gz
guix-ed907c7a29b1bdc143d148cccf7e5d1967fcb50b.zip
gnu: go-github-com-muesli-termenv: Move to golang-xyz.
* gnu/packages/golang.scm (go-github-com-muesli-termenv): Move from here ... * gnu/packages/golang-xyz.scm: ... to here. Change-Id: Iba509c25f56581aeb34508ad0db98fe85a24d135
-rw-r--r--gnu/packages/golang-xyz.scm34
-rw-r--r--gnu/packages/golang.scm31
2 files changed, 34 insertions, 31 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index e42adbf56a..7fcbb27485 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -16,6 +16,7 @@
;;; Copyright © 2020, 2021 raingloom <raingloom@riseup.net>
;;; Copyright © 2021 Collin J. Doering <collin@rekahsoft.ca>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2021 Guix Together <jgart@dismail.de>
;;; Copyright © 2021 Raghav Gururajan <rg@raghavgururajan.name>
;;; Copyright © 2021 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2021 Sarah Morgensen <iskarian@mgsn.dev>
@@ -4481,6 +4482,39 @@ Authentication Modules, PAM} application API.")
"This package provides a cancelable reader for Go.")
(license license:expat)))
+(define-public go-github-com-muesli-termenv
+ (package
+ (name "go-github-com-muesli-termenv")
+ (version "0.15.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/muesli/termenv")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "19yhli6k79aqpra4djp0cl4q76mqxbc1f7in20y0dzhnjb7yz42p"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/muesli/termenv"))
+ (propagated-inputs
+ (list go-github-com-aymanbagabas-go-osc52-v2
+ go-github-com-lucasb-eyer-go-colorful
+ go-github-com-mattn-go-isatty
+ go-github-com-mattn-go-runewidth
+ go-golang-org-x-sys))
+ (home-page "https://github.com/muesli/termenv/")
+ (synopsis "Advanced styling options on the terminal")
+ (description
+ "termenv lets you safely use advanced styling options on the terminal.
+It gathers information about the terminal environment in terms of its ANSI and
+color support and offers you convenient methods to colorize and style your
+output, without you having to deal with all kinds of weird ANSI escape
+sequences and color conversions.")
+ (license license:expat)))
+
(define-public go-github-com-multiformats-go-base32
(package
(name "go-github-com-multiformats-go-base32")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 55cff297cf..8476bb43fb 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -6089,37 +6089,6 @@ matching and globbing with support for \"doublestar\" patterns.")
helping you to transform blocks of text.")
(license license:expat)))
-(define-public go-github-com-muesli-termenv
- (package
- (name "go-github-com-muesli-termenv")
- (version "0.15.2")
- (source (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/muesli/termenv")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32
- "19yhli6k79aqpra4djp0cl4q76mqxbc1f7in20y0dzhnjb7yz42p"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/muesli/termenv"))
- (propagated-inputs
- (list go-github-com-aymanbagabas-go-osc52-v2
- go-github-com-lucasb-eyer-go-colorful
- go-github-com-mattn-go-isatty
- go-github-com-mattn-go-runewidth
- go-golang-org-x-sys))
- (home-page "https://github.com/muesli/termenv/")
- (synopsis "Advanced styling options on the terminal")
- (description "termenv lets you safely use advanced styling options on the
-terminal. It gathers information about the terminal environment in terms of
-its ANSI and color support and offers you convenient methods to colorize and
-style your output, without you having to deal with all kinds of weird ANSI
-escape sequences and color conversions.")
- (license license:expat)))
-
(define-public go-github-com-olekukonko-tablewriter
(package
(name "go-github-com-olekukonko-tablewriter")