aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-08-23 16:25:51 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-08-23 17:05:18 +0100
commite4391ff7e54eba3d99b2f4659f245149e39a270d (patch)
tree68067c18b01d471d81b6d2c6a289caba7ea6e85b
parent6e6e991cd4093c68dcb081d65ed4df92883d44b2 (diff)
downloadguix-e4391ff7e54eba3d99b2f4659f245149e39a270d.tar.gz
guix-e4391ff7e54eba3d99b2f4659f245149e39a270d.zip
gnu: Add go-github-com-muesli-cancelreader.
* gnu/packages/golang-xyz.scm (go-github-com-muesli-cancelreader): New variable. Change-Id: I514152f2ffc2fe535ee48c3f8912578238155d9f
-rw-r--r--gnu/packages/golang-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 0b9ebde3e1..e42adbf56a 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -4456,6 +4456,31 @@ Authentication Modules, PAM} application API.")
((#:import-path _ "github.com/msteinert/pam")
"github.com/msteinert/pam/v2")))))
+(define-public go-github-com-muesli-cancelreader
+ (package
+ (name "go-github-com-muesli-cancelreader")
+ (version "0.2.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/muesli/cancelreader")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0157mgpk0z45xizrgrz73swhky0d8nyk6fhwb089n1290k7yjhxq"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/muesli/cancelreader"))
+ (propagated-inputs
+ (list go-golang-org-x-sys))
+ (home-page "https://github.com/muesli/cancelreader")
+ (synopsis "Cancelable reader for Golang")
+ (description
+ "This package provides a cancelable reader for Go.")
+ (license license:expat)))
+
(define-public go-github-com-multiformats-go-base32
(package
(name "go-github-com-multiformats-go-base32")