aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-23 12:42:13 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:23:30 +0000
commitecae6bb621278763f201259ef49f30804c04e996 (patch)
tree8814ad30d5ca528fe653e2958e86406bf8482a03
parent1c5a93389ccebe69f2b80529fa4e0c8d72137939 (diff)
downloadguix-ecae6bb621278763f201259ef49f30804c04e996.tar.gz
guix-ecae6bb621278763f201259ef49f30804c04e996.zip
gnu: python-trio: Update to 0.27.0.
* gnu/packages/python-xyz.scm (python-trio): Update to 0.27.0. [arguments]<test-flags>: Disable more failing tests. <phases>: Remove 'patch-sleep as resolved upstream. Remove change-home, add 'set-env phase. [native-inputs]: Remove python-ipython, python-pylint, python-pytest-xdist, and python-pytest-cov; add python-isort and python-pytest-asyncio. Change-Id: I0f05649e05c76f556a9b23035c23c90b67ab8014
-rw-r--r--gnu/packages/python-xyz.scm30
1 files changed, 15 insertions, 15 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 6b55d31e71..4850b18e45 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29939,24 +29939,27 @@ project.")
(define-public python-trio
(package
(name "python-trio")
- (version "0.21.0")
+ (version "0.27.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "trio" version))
(sha256
- (base32 "04qwzy4295ajxpns0hrmn3asma80sjpimzpb3i877vwynsvkjgsj"))))
+ (base32 "0cb8qy1yj274xa21nf2jpmwssjzp39vgva7y982xmci62ymrbk0x"))))
(build-system pyproject-build-system)
(arguments
(list
#:test-flags
'(list "-k"
(string-append
- ;; This test times out.
+ ;; This tests times out.
"not test_ki_protection_works"
+ " and not test_KI_interrupts"
;; This fails with: signal only works in main thread of the main interpreter
" and not test_catch_signals_race_condition_on_exit"
;; Assertion errors.
+ " and not test_named_thread_os"
+ " and not test_has_pthread_setname_np"
" and not test_guest_mode_ki"
" and not test_run_in_trio_thread_ki"
" and not test_simple_cancel_scope_usage_doesnt_create\
@@ -29979,27 +29982,24 @@ _cyclic_garbage"
" and not test_getprotobyname"
;; EOFError: Ran out of input.
" and not test_static_tool_sees_all_symbols")
- "trio/tests")
+ ;; It rerquires black and ruff to generate a final report.
+ "--ignore=src/trio/_tests/tools/test_gen_exports.py"
+ "src/trio/_tests")
#:phases
'(modify-phases %standard-phases
- (add-after 'unpack 'patch-sleep
- (lambda _
- (substitute* "trio/tests/test_subprocess.py"
- (("/bin/sleep")
- (which "sleep")))))
- (add-before 'check 'change-home
+ (add-before 'check 'set-env
(lambda _
;; Tests require a writable home.
- (setenv "HOME" "/tmp"))))))
+ (setenv "HOME" "/tmp")
+ ;; #$output is first in path which causes "import file mismatch"
+ (setenv "PYTHONPATH" (string-append (getcwd) "/src:$PYTHONPATH")))))))
(native-inputs
(list python-astor
- python-ipython
python-jedi
- python-pylint
python-pyopenssl
python-pytest
- python-pytest-xdist
- python-pytest-cov
+ python-isort
+ python-pytest-asyncio
python-trustme
python-setuptools
python-wheel))