aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-11-23 12:42:12 +0000
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:23:30 +0000
commit1c5a93389ccebe69f2b80529fa4e0c8d72137939 (patch)
tree8f13942051dc421b28f229e9ee1d08fd889b083a
parentf719b0136a741cbfaa17efbf641c4483811c631f (diff)
downloadguix-1c5a93389ccebe69f2b80529fa4e0c8d72137939.tar.gz
guix-1c5a93389ccebe69f2b80529fa4e0c8d72137939.zip
gnu: python-sniffio: Update to 1.3.1.
* gnu/packages/python-xyz.scm (python-sniffio): Update to 1.3.1. [build-system]: Swap to pyproject-build-system. [arguments]<phases>: Use default 'check phase. [native-inputs]: Add python-setuptools and python-wheel. Change-Id: I4a657235ad061721d8ca5193ed3318aa13e1b5a7
-rw-r--r--gnu/packages/python-xyz.scm18
1 files changed, 8 insertions, 10 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 2dfbd8f0ba..6b55d31e71 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16743,22 +16743,20 @@ subtasks.")
(define-public python-sniffio
(package
(name "python-sniffio")
- (version "1.2.0")
+ (version "1.3.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "sniffio" version))
(sha256
- (base32 "1pnkvi6wvn4qd37y69n1ls6n8l63gfmn3pvb1jb50gqxxkn6wrn4"))))
- (build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda _
- (invoke "pytest" "-vv"))))))
+ (base32 "1p496yran6zwg47m7w26r8y89nrsbkrrbf4119slj3qaczf4wcpl"))))
+ (build-system pyproject-build-system)
(native-inputs
- (list python-curio python-pytest python-pytest-cov))
+ (list python-curio
+ python-pytest
+ python-pytest-cov
+ python-setuptools
+ python-wheel))
(home-page "https://github.com/python-trio/sniffio")
(synopsis "Detect which async library a program is running under")
(description "This package detects which async library a program is