diff options
author | Lars-Dominik Braun <lars@6xq.net> | 2023-05-13 16:20:23 +0200 |
---|---|---|
committer | Sharlatan Hellseher <sharlatanus@gmail.com> | 2024-12-13 20:15:42 +0000 |
commit | eabed5e53d16cd37404614fd299656823d09f9e7 (patch) | |
tree | 3ed6532029239a19df4f46761157e47ee5e03f3c | |
parent | d4e7ce92e33173bb87d664bb67d1216a4f719239 (diff) | |
download | guix-eabed5e53d16cd37404614fd299656823d09f9e7.tar.gz guix-eabed5e53d16cd37404614fd299656823d09f9e7.zip |
gnu: sssd: Import ensure-no-mtimes-pre-1980.
* gnu/packages/sssd.scm (sssd)[arguments]: Add
python-build-system to #:modules and #:imported modules instead of using
@@ reference.
Change-Id: Id5217e4872a62323691b8976030a1768a6885942
-rw-r--r-- | gnu/packages/sssd.scm | 9 |
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/sssd.scm b/gnu/packages/sssd.scm index 6fb43195e7..d0dd0c400a 100644 --- a/gnu/packages/sssd.scm +++ b/gnu/packages/sssd.scm @@ -31,6 +31,7 @@ #:use-module (guix utils) #:use-module (guix build utils) #:use-module (guix build-system gnu) + #:use-module (guix build-system python) #:use-module (gnu packages) #:use-module (gnu packages) #:use-module (gnu packages adns) @@ -182,10 +183,16 @@ fundamental object types for C.") (string-append "--with-xml-catalog-path=" #$(this-package-native-input "docbook-xml") "/xml/dtd/docbook/catalog.xml")) + #:modules '((guix build gnu-build-system) + (guix build utils) + ((guix build python-build-system) + #:select (ensure-no-mtimes-pre-1980))) + #:imported-modules (append %default-gnu-imported-modules + %python-build-system-modules) #:phases #~(modify-phases %standard-phases (add-after 'unpack 'ensure-no-mtimes-pre-1980 - (@@ (guix build python-build-system) ensure-no-mtimes-pre-1980)) + ensure-no-mtimes-pre-1980) (add-after 'patch-source-shebangs 'patch-more-shebangs (lambda _ (substitute* '("src/tools/analyzer/sss_analyze" |