aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars-Dominik Braun <lars@6xq.net>2023-05-13 15:31:22 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:15:42 +0000
commitd4e7ce92e33173bb87d664bb67d1216a4f719239 (patch)
treec72864306faf3ffa1d3c522b5e971826149a279a
parent275123dbd9c5954bc08c52c4ec92dff427153d94 (diff)
downloadguix-d4e7ce92e33173bb87d664bb67d1216a4f719239.tar.gz
guix-d4e7ce92e33173bb87d664bb67d1216a4f719239.zip
gnu: criu: Remove temporary workaround.
* gnu/packages/virtualization.scm (criu)[arguments]: Import ensure-no-mtimes-pre-1980 from python-build-system and remove copied code. Change-Id: I2ab9eb51dfa66fcf5b0144eab73d63055400e30c
-rw-r--r--gnu/packages/virtualization.scm19
1 files changed, 7 insertions, 12 deletions
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index ac410d099c..c0ca83b5a0 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -1995,8 +1995,12 @@ client desktops.
(string-append "XMLTO="
(search-input-file %build-inputs
"/bin/xmlto")))
- #:modules ((ice-9 ftw)
- ,@%default-gnu-modules)
+ #:modules ((guix build gnu-build-system)
+ (guix build utils)
+ ((guix build python-build-system)
+ #:select (ensure-no-mtimes-pre-1980)))
+ #:imported-modules ,(append %default-gnu-imported-modules
+ %python-build-system-modules)
#:phases
(modify-phases %standard-phases
(delete 'configure) ; no configure script
@@ -2008,17 +2012,8 @@ client desktops.
;; Hard-code the correct PLUGINDIR above.
(substitute* "criu/include/plugin.h"
(("/var") (string-append (assoc-ref outputs "out"))))))
- ;; TODO: use
- ;; (@@ (guix build python-build-system) ensure-no-mtimes-pre-1980)
- ;; when it no longer throws due to trying to call UTIME on symlinks.
(add-after 'unpack 'ensure-no-mtimes-pre-1980
- (lambda _
- (let ((early-1980 315619200)) ; 1980-01-02 UTC
- (ftw "." (lambda (file stat flag)
- (unless (or (<= early-1980 (stat:mtime stat))
- (eq? (stat:type stat) 'symlink))
- (utime file early-1980 early-1980))
- #t)))))
+ ensure-no-mtimes-pre-1980)
(add-before 'build 'fix-symlink
(lambda* (#:key inputs #:allow-other-keys)
;; The file 'images/google/protobuf/descriptor.proto' points to