aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-08-20 17:08:03 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-08-23 22:29:17 +0800
commite3ab05320ddd7b1305ccfbda55df29543f5e5883 (patch)
tree2d384b23690fc9cea2bad2b3ddac2dea916a3beb
parentbf3482bc4d1be81d4b4eea0c08b403544dd186b8 (diff)
downloadguix-e3ab05320ddd7b1305ccfbda55df29543f5e5883.tar.gz
guix-e3ab05320ddd7b1305ccfbda55df29543f5e5883.zip
gnu: protobuf-c: Fix cross-compilation.
* gnu/packages/protobuf.scm (protobuf-c): Fix cross-compilation. [native-inputs]: When cross-compilation, add protobuf. [arguments]<#:configure-flags>: When cross-compilation, Set PROTOC variable. Change-Id: Idd660f526b7c90277cb4399997cdb7ce72e4f1c5 Signed-off-by: Zheng Junjie <zhengjunjie@iscas.ac.cn>
-rw-r--r--gnu/packages/protobuf.scm14
1 files changed, 12 insertions, 2 deletions
diff --git a/gnu/packages/protobuf.scm b/gnu/packages/protobuf.scm
index d47b67fa61..b8679eff25 100644
--- a/gnu/packages/protobuf.scm
+++ b/gnu/packages/protobuf.scm
@@ -8,7 +8,7 @@
;;; Copyright © 2020 Vinicius Monego <monego@posteo.net>
;;; Copyright © 2020 Brett Gilio <brettg@gnu.org>
;;; Copyright © 2021 Felix Gruber <felgru@posteo.net>
-;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
+;;; Copyright © 2023, 2024 Zheng Junjie <873216071@qq.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -262,7 +262,17 @@ internal RPC protocols and file formats.")
"17rk42r3gcc46c2svd1mxs542wnl4mi77a6klkhg6wl1a36zmi2c"))))
(build-system gnu-build-system)
(inputs (list protobuf))
- (native-inputs (list pkg-config))
+ (native-inputs (append (if (%current-target-system)
+ (list protobuf)
+ '())
+ (list pkg-config)))
+ (arguments (if (%current-target-system)
+ (list #:configure-flags
+ #~(list
+ (string-append
+ "PROTOC="
+ (search-input-file %build-inputs "bin/protoc"))))
+ (list)))
(home-page "https://github.com/protobuf-c/protobuf-c")
(synopsis "Protocol Buffers implementation in C")
(description