aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZheng Junjie <zhengjunjie@iscas.ac.cn>2024-08-23 14:02:14 +0800
committerZheng Junjie <zhengjunjie@iscas.ac.cn>2024-08-23 22:29:17 +0800
commitbf3482bc4d1be81d4b4eea0c08b403544dd186b8 (patch)
tree526e694dc745c68f3dfac86ab2ee99aa992748fe
parent883e900e514a22fe9813f33c691c753e9a1289c5 (diff)
downloadguix-bf3482bc4d1be81d4b4eea0c08b403544dd186b8.tar.gz
guix-bf3482bc4d1be81d4b4eea0c08b403544dd186b8.zip
gnu: kanshi: Fix cross-compilation.
* gnu/packages/wm.scm (kanshi)[native-inputs]: Add wayland. Remove libscfg. When cross-compilation, Add pkg-config-for-build. [inputs]: Add libscfg. Change-Id: I45c17196dfc85157afa31dd4ae6db579dfc37723
-rw-r--r--gnu/packages/wm.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 16a85981f4..e2d863a1a3 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -2374,8 +2374,11 @@ compositors that support the layer-shell protocol.")
(sha256
(base32 "0g5glpkcn54ypfym4lpfdjai479yfazcai1rg86bn72nkcbpwfql"))))
(build-system meson-build-system)
- (inputs (list wayland))
- (native-inputs (list pkg-config scdoc libscfg))
+ (inputs (list libscfg wayland))
+ (native-inputs (append (if (%current-target-system)
+ (list pkg-config-for-build)
+ (list))
+ (list pkg-config scdoc wayland)))
(home-page "https://wayland.emersion.fr/kanshi")
(synopsis "Hotswappable output profiles for Wayland")
(description "Kanshi allows you to define output profiles that are