aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 18:43:26 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:29 +0200
commite31cfb0981778cd7aeb67fac35ada6bc0666636f (patch)
tree7ba28f340fd721a69027444655792a41cd353ce7
parente9f165ee9ca5ed1715d038af838b6aecdf12003c (diff)
downloadguix-e31cfb0981778cd7aeb67fac35ada6bc0666636f.tar.gz
guix-e31cfb0981778cd7aeb67fac35ada6bc0666636f.zip
gnu: texlive-newtx: Refresh package definition.
* gnu/packages/tex.scm (texlive-newtx): Remove SIMPLE-TEXLIVE-PACKAGE call. [propagated-inputs]: Add TEXLIVE-AMSMATH, TEXLIVE-CARLISLE, TEXLIVE-ETEXTOOLS, TEXLIVE-ETOOLBOX, TEXLIVE-FONTAXES, TEXLIVE-IFTEX, TEXLIVE-OBERDIEK, TEXLIVE-TRIMSPACES, TEXLIVE-XSTRING, TEXLIVE-XKEYVAL.
-rw-r--r--gnu/packages/tex.scm58
1 files changed, 36 insertions, 22 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 1f661dc6fc..0d70b8f666 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -11305,30 +11305,44 @@ use with [pdf]LaTeX.")
(define-public texlive-newtx
(package
- (inherit (simple-texlive-package
- "texlive-newtx"
- (list "/doc/fonts/newtx/"
- "/fonts/afm/public/newtx/"
- "/fonts/enc/dvips/newtx/"
- "/fonts/map/dvips/newtx/"
- "/fonts/opentype/public/newtx/"
- "/fonts/tfm/public/newtx/"
- "/fonts/type1/public/newtx/"
- "/fonts/vf/public/newtx/"
- "/tex/latex/newtx/")
- (base32
- "0h0wm3cd0wxag5x7vy3vgr42jd8m6ffkl90pnkvqdxzbnfdjv3l6")
- #:trivial? #t))
+ (name "texlive-newtx")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "/doc/fonts/newtx/"
+ "/fonts/afm/public/newtx/"
+ "/fonts/enc/dvips/newtx/"
+ "/fonts/map/dvips/newtx/"
+ "/fonts/opentype/public/newtx/"
+ "/fonts/tfm/public/newtx/"
+ "/fonts/type1/public/newtx/"
+ "/fonts/vf/public/newtx/"
+ "/tex/latex/newtx/")
+ (base32
+ "0h0wm3cd0wxag5x7vy3vgr42jd8m6ffkl90pnkvqdxzbnfdjv3l6")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs
+ (list texlive-amsmath
+ texlive-carlisle
+ texlive-etextools
+ texlive-etoolbox
+ texlive-fontaxes
+ texlive-iftex
+ texlive-oberdiek
+ texlive-trimspaces
+ texlive-xkeyval
+ texlive-xstring))
(home-page "https://www.ctan.org/pkg/newtx")
(synopsis "Repackaging of the TX fonts with improved metrics")
- (description "The @code{newtx} bundle splits
-@code{txfonts.sty} (from the TX fonts distribution) into two
-independent packages, @code{newtxtext.sty} and @code{newtxmath.sty},
-each with fixes and enhancements. @code{newtxmath}'s metrics have
-been re-evaluated to provide a less tight appearance and to provide a
-@code{libertine} option that substitutes Libertine italic and Greek
-letters for the existing math italic and Greek glyphs, making a
-mathematics package that matches Libertine text quite well.")
+ (description
+ "The @code{newtx} bundle splits @file{txfonts.sty} (from the TX fonts
+distribution) into two independent packages, @code{newtxtext.sty} and
+@code{newtxmath.sty}, each with fixes and enhancements. @code{newtxmath}'s
+metrics have been re-evaluated to provide a less tight appearance and to
+provide a @code{libertine} option that substitutes Libertine italic and Greek
+letters for the existing math italic and Greek glyphs, making a mathematics
+package that matches Libertine text quite well.")
(license license:lppl1.3)))
(define-public texlive-xcharter