aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 18:48:12 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:28 +0200
commite9f165ee9ca5ed1715d038af838b6aecdf12003c (patch)
tree124dd599f8654a37b07c63f5f78e57d5dbfb791d
parent06b17a52b79e6c3955b7ef1524aa4399eb33c9c9 (diff)
downloadguix-e9f165ee9ca5ed1715d038af838b6aecdf12003c.tar.gz
guix-e9f165ee9ca5ed1715d038af838b6aecdf12003c.zip
gnu: Add texlive-etextools.
* gnu/packages/tex.scm (texlive-etextools): New variable.
-rw-r--r--gnu/packages/tex.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 9dad5030bd..1f661dc6fc 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -9764,6 +9764,33 @@ adding a prefix to e-TeX’s commands. For example, ε-TeX’s
(define-deprecated-package texlive-generic-etexcmds texlive-etexcmds)
+(define-public texlive-etextools
+ (package
+ (name "texlive-etextools")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/etextools/"
+ "source/latex/etextools/"
+ "tex/latex/etextools/")
+ (base32
+ "0bfcc8g8q5v1nyqmrg8n17hv4k8yvhsplansvriccpmvyx0w9y9d")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs
+ (list texlive-etex
+ texlive-etoolbox
+ texlive-letltxmacro))
+ (home-page "https://ctan.org/pkg/etextools")
+ (synopsis "e-TeX tools for LaTeX users and package writers")
+ (description
+ "The package provides many (purely expandable) tools for LaTeX: extensive
+list management; purely expandable loops; conversion; addition/deletion;
+expansion and group control; tests on tokens, characters and control
+sequences; tests on strings; purely expandable macros with options or
+modifiers; some purely expandable numerics.")
+ (license license:lppl)))
+
(define-public texlive-gettitlestring
(let ((template (simple-texlive-package
"texlive-gettitlestring"