aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 23:29:41 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:50 +0200
commite1d1b4f992ffa92d3e8e0ddfa4ec570ff94f006a (patch)
tree8958551abe701779ea5f4b7e96df91e63ebb469f
parenta11405bffe188f6eef3919845cbaca0eae455191 (diff)
downloadguix-e1d1b4f992ffa92d3e8e0ddfa4ec570ff94f006a.tar.gz
guix-e1d1b4f992ffa92d3e8e0ddfa4ec570ff94f006a.zip
gnu: texlive-eso-pic: Refresh package definition.
* gnu/packages/tex.scm (texlive-eso-pic): Remove SIMPLE-TEXLIVE-PACKAGE call.
-rw-r--r--gnu/packages/tex.scm37
1 files changed, 16 insertions, 21 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2b93e79349..596ea5c83c 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7440,29 +7440,24 @@ via one of the packages @code{calrsfs} and @code{mathrsfs}.")
(define-deprecated-package texlive-fonts-rsfs texlive-rsfs)
(define-public texlive-eso-pic
- (let ((template (simple-texlive-package
- "texlive-eso-pic"
- (list "doc/latex/eso-pic/"
- "source/latex/eso-pic/"
- "tex/latex/eso-pic/")
- (base32
- "05bqm4x209wji0q6xk1jrjp0nzqafp44dlq30hlpcagrggjb3d9s"))))
- (package
- (inherit template)
- (outputs '("out" "doc"))
- (arguments
- (substitute-keyword-arguments (package-arguments template)
- ((#:tex-directory _ '())
- "latex/eso-pic")
- ((#:build-targets _ '())
- #~(list "eso-pic.ins"))))
- (home-page "https://ctan.org/macros/latex/contrib/eso-pic")
- (synopsis "Add picture commands (or backgrounds) to every page")
- (description
- "The package adds one or more user commands to LaTeX's @code{shipout}
+ (package
+ (name "texlive-eso-pic")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/eso-pic/" "source/latex/eso-pic/"
+ "tex/latex/eso-pic/")
+ (base32
+ "05bqm4x209wji0q6xk1jrjp0nzqafp44dlq30hlpcagrggjb3d9s")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/eso-pic")
+ (synopsis "Add picture commands (or backgrounds) to every page")
+ (description
+ "The package adds one or more user commands to LaTeX's @code{shipout}
routine, which may be used to place the output at fixed positions. The
@code{grid} option may be used to find the correct places.")
- (license license:lppl1.3+))))
+ (license license:lppl1.3+)))
(define-deprecated-package texlive-latex-eso-pic texlive-eso-pic)