aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 23:28:54 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:49 +0200
commita11405bffe188f6eef3919845cbaca0eae455191 (patch)
tree7843291cee0adaa3c0f9a9ee66d2e2610293cae0
parentc0011a5d0b1d1160ebd4f02f5a545c498ab70e8c (diff)
downloadguix-a11405bffe188f6eef3919845cbaca0eae455191.tar.gz
guix-a11405bffe188f6eef3919845cbaca0eae455191.zip
gnu: texlive-kvoptions: Refresh package definition.
* gnu/packages/tex.scm (texlive-kvoptions): Remove SIMPLE-TEXLIVE-PACKAGE call.
-rw-r--r--gnu/packages/tex.scm42
1 files changed, 19 insertions, 23 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 34fc53337b..2b93e79349 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -7058,30 +7058,26 @@ in SGML; use maths minus in text as appropriate; simple Young tableaux.")
(define-deprecated-package texlive-jknappen texlive-jknapltx)
(define-public texlive-kvoptions
- (let ((template (simple-texlive-package
- "texlive-kvoptions"
- (list "doc/latex/kvoptions/"
- "source/latex/kvoptions/"
- "tex/latex/kvoptions/")
- (base32
- "1b8q93l54160b8gn3fq484n15n6cylrhmf2xk7p42czg2rqw7w3l"))))
- (package
- (inherit template)
- (outputs '("out" "doc"))
- (arguments
- (substitute-keyword-arguments (package-arguments template)
- ((#:tex-directory _ '())
- "latex/kvoptions")
- ((#:build-targets _ '())
- #~(list "kvoptions.dtx"))))
- (propagated-inputs
- (list texlive-kvsetkeys texlive-ltxcmds))
- (home-page "https://www.ctan.org/pkg/kvoptions")
- (synopsis "Key/value format for package options")
- (description
- "This package provides facilities for using key-value format in
+ (package
+ (name "texlive-kvoptions")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/kvoptions/"
+ "source/latex/kvoptions/"
+ "tex/latex/kvoptions/")
+ (base32
+ "1b8q93l54160b8gn3fq484n15n6cylrhmf2xk7p42czg2rqw7w3l")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs
+ (list texlive-kvsetkeys texlive-ltxcmds))
+ (home-page "https://www.ctan.org/pkg/kvoptions")
+ (synopsis "Key/value format for package options")
+ (description
+ "This package provides facilities for using key-value format in
package options.")
- (license license:lppl1.3c+))))
+ (license license:lppl1.3c+)))
(define-deprecated-package texlive-latex-kvoptions texlive-kvoptions)