aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVincent Legoll <vincent.legoll@gmail.com>2024-11-25 23:00:13 +0100
committerGuillaume Le Vaillant <glv@posteo.net>2024-11-26 15:21:44 +0100
commite11ab2a6e9628af6c37d4ae5e0faabde79bcea34 (patch)
tree34afc8fb5ea3c2535d91fb89466e12884170b139
parent1283f5cd4027de9aa97ee888a8d17cb0fe49bf0c (diff)
downloadguix-e11ab2a6e9628af6c37d4ae5e0faabde79bcea34.tar.gz
guix-e11ab2a6e9628af6c37d4ae5e0faabde79bcea34.zip
gnu: Add ondsel-solver.
* gnu/packages/engineering.scm (ondsel-solver): New variable. Change-Id: Ie966b13d1ec5351ef8b9f2459780f3da47f96db8 Signed-off-by: Guillaume Le Vaillant <glv@posteo.net>
-rw-r--r--gnu/packages/engineering.scm29
1 files changed, 28 insertions, 1 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 3ceeb4425a..699b14dd90 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -15,7 +15,7 @@
;;; Copyright © 2019 Steve Sprang <scs@stevesprang.com>
;;; Copyright © 2019 John Soo <jsoo1@asu.edu>
;;; Copyright © 2020 Brice Waegeneire <brice@waegenei.re>
-;;; Copyright © 2020,2021 Vincent Legoll <vincent.legoll@gmail.com>
+;;; Copyright © 2020,2021,2024 Vincent Legoll <vincent.legoll@gmail.com>
;;; Copyright © 2020, 2023 Marius Bakke <marius@gnu.org>
;;; Copyright © 2020, 2021 Ekaitz Zarraga <ekaitz@elenq.tech>
;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
@@ -2930,6 +2930,33 @@ full programmatic control over your models.")
OpenSCAD code. It supports syntax highlighting, indenting and refilling of
comments.")))
+(define-public ondsel-solver
+ (let ((commit "2e3659c4bce3e6885269e0cb3d640261b2a91108")
+ (revision "1"))
+ (package
+ (name "ondsel-solver")
+ ;; There's no tagged release
+ (version (git-version "0.0.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Ondsel-Development/OndselSolver")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1bgk3asyz47r1kvdgcz8q7sh1g29przdsx9ib1jqqbc0nv8ww68v"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f)) ;; Tests require Google's gtest and gmock
+ ;; The company is shutting down, so https://ondsel.com may not exist for long
+ (home-page "https://github.com/Ondsel-Development/OndselSolver")
+ (synopsis "Assembly Constraints and Multibody Dynamics code")
+ (description
+ "The OndselSolver library for assembly constraints and multibody
+dynamics is used by FreeCAD 1.0.0 for its new Assembly workbench.")
+ (license license:lgpl2.1+))))
+
(define-public freecad
(package
(name "freecad")