aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNavid Afkhami <navid.afkhami@mdc-berlin.de>2024-11-26 13:31:03 +0000
committerRicardo Wurmus <rekado@elephly.net>2024-11-26 15:13:25 +0100
commit1283f5cd4027de9aa97ee888a8d17cb0fe49bf0c (patch)
tree61193a28ce99b3f7eb7c2eb7b01491ae399bf6e8
parent2bda81fadc82aa0aba1da2476192be0cd0c4ed4d (diff)
downloadguix-1283f5cd4027de9aa97ee888a8d17cb0fe49bf0c.tar.gz
guix-1283f5cd4027de9aa97ee888a8d17cb0fe49bf0c.zip
gnu: Add r-highs.
* gnu/packages/cran.scm (r-highs): New variable. Change-Id: I181f036f5df65a7e1ec6fc1a6646da22686d5895 Signed-off-by: Ricardo Wurmus <rekado@elephly.net> Co-authored-by: Ricardo Wurmus <rekado@elephly.net>
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 599238d0d8..c5ac9fbb2e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -70,6 +70,7 @@
#:use-module (gnu packages base)
#:use-module (gnu packages bioinformatics)
#:use-module (gnu packages c)
+ #:use-module (gnu packages cmake)
#:use-module (gnu packages compression)
#:use-module (gnu packages crypto)
#:use-module (gnu packages curl)
@@ -39757,6 +39758,28 @@ includes a custom Sweave driver performing syntax highlighting of R code
chunks.")
(license license:gpl3+)))
+(define-public r-highs
+ (package
+ (name "r-highs")
+ (version "0.1-10")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "highs" version))
+ (sha256
+ (base32 "1vjmzbfydlm434fa1mkwwfcdhmn6sq4ppib26nxfa9zakr7h7q2c"))))
+ (properties `((upstream-name . "highs")))
+ (build-system r-build-system)
+ (propagated-inputs (list r-checkmate r-pkgconfig r-rcpp))
+ (native-inputs (list cmake-minimal gfortran which))
+ (home-page "https://gitlab.com/roigrp/solver/highs")
+ (synopsis "'HiGHS' Optimization Solver")
+ (description
+ "This package provides an R interface to @code{HiGHS}, an optimization
+solver. It is designed for solving mixed-integer optimization problems with
+quadratic or linear objectives and linear constraints.")
+ (license license:gpl2+)))
+
(define-public r-clustree
(package
(name "r-clustree")