aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-12-09 20:47:14 +0900
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-12-17 23:43:58 +0900
commitd5e05b6548e1bad49f3b0881d21fb98eb3df0b0f (patch)
treede6b8f21b999bef5e0aeccb045c8b13e6b4227cd
parentde6d8b7c7daa4add3725299550fbc6ffa9cd3926 (diff)
downloadguix-d5e05b6548e1bad49f3b0881d21fb98eb3df0b0f.tar.gz
guix-d5e05b6548e1bad49f3b0881d21fb98eb3df0b0f.zip
gnu: python-pytest-cython: Remove extraneous python-nox native input.
* gnu/packages/python-check.scm (python-pytest-cython) [native-inputs]: Remove python-nox. Change-Id: I585b17d63e52e62fd7c633354b74e4ae6233f722
-rw-r--r--gnu/packages/python-check.scm8
1 files changed, 2 insertions, 6 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index aa3d03ed51..ebfbbf26d4 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -1971,12 +1971,8 @@ plain (undecoratored) native coroutine tests.")
(lambda _
(with-directory-excursion "tests/example-project"
(invoke "python" "setup.py" "build_ext" "--inplace")))))))
- (native-inputs
- (list python-nox
- python-cython-3
- python-setuptools))
- (propagated-inputs
- (list python-pytest))
+ (native-inputs (list python-cython-3 python-setuptools))
+ (propagated-inputs (list python-pytest))
(home-page "https://github.com/lgpage/pytest-cython")
(synopsis "Cython extension modules testing plugin")
(description