aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-12-17 22:33:07 +0900
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2024-12-17 23:43:58 +0900
commitde6d8b7c7daa4add3725299550fbc6ffa9cd3926 (patch)
tree264a0d966a70d8af3f5ce63a67d7d1fcde25e948
parent106809a3065c3dcfb39af2651af5d5e4fc5884e5 (diff)
downloadguix-de6d8b7c7daa4add3725299550fbc6ffa9cd3926.tar.gz
guix-de6d8b7c7daa4add3725299550fbc6ffa9cd3926.zip
gnu: python-tox: Update to 4.8.0 and disable tests.
* gnu/packages/python-check.scm (python-tox): Update to 4.8.0. [build-system]: Switch to pyproject-build-system. [arguments]: Delete #:phases. Add #:test-flags. [propagated-inputs]: Remove python-py, python-six and python-toml. Add python-cachetools, python-chardet, python-colorama, python-platformdirs, python-pyproject-api and python-tomli. [native-inputs]: Remove python-pathlib2, python-pytest-freezegun, python-pytest-timeout, python-setuptools-scm. Add python-distlib, python-hatchling, python-hatch-vcs, python-psutil, python-pytest-mock, python-pytest-xdist and python-re-assert. Change-Id: I7c58649ac4c0fcb72e5009a7a2a06570e28d3eff
-rw-r--r--gnu/packages/python-check.scm73
1 files changed, 22 insertions, 51 deletions
diff --git a/gnu/packages/python-check.scm b/gnu/packages/python-check.scm
index a276452a69..aa3d03ed51 100644
--- a/gnu/packages/python-check.scm
+++ b/gnu/packages/python-check.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2019, 2021-2024 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2019, 2020, 2021, 2022, 2023 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2019, 2020, 2021, 2022, 2023, 2024 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2019, 2021 Hartmut Goebel <h.goebel@crazy-compilers.com>
;;; Copyright © 2020, 2022 Julien Lepiller <julien@lepiller.eu>
;;; Copyright © 2020, 2022 Marius Bakke <marius@gnu.org>
@@ -2907,67 +2907,38 @@ Python file for configuration.")
(define-public python-tox
(package
(name "python-tox")
- (version "3.20.0")
+ (version "4.8.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "tox" version))
(sha256
(base32
- "0nk0nyzhzamcrvn0qqzzy54isxxqwdi28swml7a2ym78c3f9sqpb"))))
- (build-system python-build-system)
- (arguments
- (list
- #:phases
- #~(modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-vv" "-k"
- (string-join
- (map (lambda (test)
- (string-append "not test_" test))
- '("invocation_error"
- "create_KeyboadInterrupt"
- "exit_code"
- "tox_get_python_executable"
- "find_alias_on_path"
- "get_executable"
- "get_executable_no_exist"
- "get_sitepackagesdir_error"
- "spinner_stdout_not_unicode"
- "provision_non_canonical_dep"
- "package_setuptools"
- "package_poetry"
- "parallel_interrupt"
- "provision_missing"
- "provision_from_pyvenv"
- "provision_interrupt_child"
- "create"
- "run_custom_install_command"
- "toxuone_env"
- "different_config_cwd"
- "test_usedevelop"
- "build_backend_without_submodule"
- "parallel"
- "parallel_live"
- "tox_env_var_flags_inserted_isolated"))
- " and "))))))))
+ "0yq3d2wif88d2iih8c2dwjx7rz8axkc7b6gskl5z3k0jbd1wznia"))))
+ (build-system pyproject-build-system)
+ (arguments (list #:tests? #f)) ;require python-devpi-process
(propagated-inputs
- (list python-filelock
+ (list python-cachetools
+ python-chardet
+ python-colorama
+ python-filelock
python-packaging
+ python-platformdirs
python-pluggy
- python-py
- python-six
- python-toml
+ python-pyproject-api
+ python-tomli
python-virtualenv))
(native-inputs
- (list python-flaky
- python-pathlib2
- python-pytest ; >= 2.3.5
- python-pytest-freezegun
- python-pytest-timeout
- python-setuptools-scm))
+ (list python-distlib
+ ;;python-devpi-process ;FIXME: package me
+ python-flaky
+ python-hatchling
+ python-hatch-vcs
+ python-psutil
+ python-pytest
+ python-pytest-mock
+ python-pytest-xdist
+ python-re-assert))
(home-page "https://tox.readthedocs.io")
(synopsis "Virtualenv-based automation of test activities")
(description "Tox is a generic virtualenv management and test command line