aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-16 17:12:41 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:34 +0200
commitce34e05b3c9ec84effdb8105cc0893f1220fc4a3 (patch)
tree133233d89f3e1b885ad14629a7fe10f700681174
parent7b9dbd67173ed8fa8b4f4ecdc325ed6bcebe5b94 (diff)
downloadguix-ce34e05b3c9ec84effdb8105cc0893f1220fc4a3.tar.gz
guix-ce34e05b3c9ec84effdb8105cc0893f1220fc4a3.zip
gnu: Add texlive-latex-git-log.
* gnu/packages/tex.scm (texlive-latex-git-log): New variable.
-rw-r--r--gnu/packages/tex.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index cc50961351..3fb5276988 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2496,6 +2496,30 @@ generated code can be included in any LaTeX document.")
"Lacheck is a tool for finding common mistakes in LaTeX documents.")
(license license:gpl3+)))
+(define-public texlive-latex-git-log
+ (package
+ (name "texlive-latex-git-log")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/man/man1/latex-git-log.1"
+ "doc/man/man1/latex-git-log.man1.pdf"
+ "doc/support/latex-git-log/"
+ "scripts/latex-git-log/")
+ (base32
+ "01v6frspg1zrs976bwsdz6qczg0h5z6by90hmlyy4z6l5shscpix")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (arguments (list #:link-scripts #~(list "latex-git-log")))
+ (inputs (list perl))
+ (home-page "https://ctan.org/pkg/latex-git-log")
+ (synopsis "Typeset @samp{git log} information")
+ (description
+ "The program is run within a Git repository, and outputs the entire
+version history, as a LaTeX table. That output will typically be redirected
+to a file; the author recommends typesetting in landscape orientation.")
+ (license license:gpl3+)))
+
(define-public texlive-tex-ini-files
(package
(name "texlive-tex-ini-files")