aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-16 17:12:03 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:18:33 +0200
commit7b9dbd67173ed8fa8b4f4ecdc325ed6bcebe5b94 (patch)
treee59bc79ed463fde5fcc1571e2cc49d1a26437f27
parentf5cb25f11379256534b6ce24bc733b5ff64f2452 (diff)
downloadguix-7b9dbd67173ed8fa8b4f4ecdc325ed6bcebe5b94.tar.gz
guix-7b9dbd67173ed8fa8b4f4ecdc325ed6bcebe5b94.zip
gnu: Add texlive-lacheck.
* gnu/packages/tex.scm (texlive-lacheck): New variable.
-rw-r--r--gnu/packages/tex.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 2fd021410f..cc50961351 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2478,6 +2478,24 @@ is a plugin for Cinderella that allows to generate graphics using KETpic. The
generated code can be included in any LaTeX document.")
(license license:gpl3+)))
+(define-public texlive-lacheck
+ (package
+ (name "texlive-lacheck")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/man/man1/lacheck.1"
+ "doc/man/man1/lacheck.man1.pdf")
+ (base32
+ "1hhx65yd800bl3y2sq20lix60wd2b2j3k7n9s788mlsn8b0p7yq3")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (home-page "https://ctan.org/pkg/lacheck")
+ (synopsis "LaTeX checker")
+ (description
+ "Lacheck is a tool for finding common mistakes in LaTeX documents.")
+ (license license:gpl3+)))
+
(define-public texlive-tex-ini-files
(package
(name "texlive-tex-ini-files")