aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-10 00:53:55 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:54 +0000
commitc9a5155ee1396872ae0de4a0569ad26f6da29b7a (patch)
tree8ecbfe392f70d65b2de37caa48ed9b5a568d25db
parent1382f7697adba7eb401580a90d40054caa8f8d51 (diff)
downloadguix-c9a5155ee1396872ae0de4a0569ad26f6da29b7a.tar.gz
guix-c9a5155ee1396872ae0de4a0569ad26f6da29b7a.zip
gnu: python-sparse: Move to pyproject-build-system.
* gnu/packages/python-xyz.scm (python-sparse): [build-system]: Move to pyproject-build-system. [arguments]: Remove unneeded field. Change-Id: If3f785ede09ef79384b66166ad2f1c2a5f6e7c84 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/python-xyz.scm9
1 files changed, 1 insertions, 8 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 458433190c..f9b9639482 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -9073,14 +9073,7 @@ objects.")
(sha256
(base32
"1600xad37mff46xg80cy6bi3l2n6jm69j7sl19rzdmkcgyijfn2z"))))
- (build-system python-build-system)
- (arguments
- `(#:phases
- (modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "python" "-m" "pytest" "-v")))))))
+ (build-system pyproject-build-system)
(propagated-inputs
(list python-numba python-numpy python-scipy))
(native-inputs