aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2024-12-31 14:36:26 +0800
committer宋文武 <iyzsong@member.fsf.org>2025-01-01 10:48:35 +0800
commitc943829ac7b25ac6326f78fe947a5d79c283627b (patch)
treeee79f394fd28bffa33eedb987e90e406db2d4096
parent0b3ebac7aceb4722f333ea429e5ed5bea074eb97 (diff)
downloadguix-c943829ac7b25ac6326f78fe947a5d79c283627b.tar.gz
guix-c943829ac7b25ac6326f78fe947a5d79c283627b.zip
gnu: xfce4-weather-plugin: Switch to git source.
* gnu/packages/xfce.scm (xfce4-weather-plugin)[source]: Switch to git-fetch. [native-inputs]: Add xfce4-dev-tools. [arguments]: Add "--enable-maintainer-mode" to configure-flags. [home-page]: Set to docs.xfce.org. Change-Id: I72bcdab8f58401347a2993172f07237082e0e80a
-rw-r--r--gnu/packages/xfce.scm31
1 files changed, 17 insertions, 14 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index d05c63be98..2f6041cc9b 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -2280,24 +2280,27 @@ lan interface (signal state, signal quality, network name (SSID)).")
(define-public xfce4-weather-plugin
(package
- (name "xfce4-weather-plugin")
- (version "0.11.3")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://archive.xfce.org/src/panel-plugins/"
- "xfce4-weather-plugin/"
- (version-major+minor version)
- "/xfce4-weather-plugin-" version ".tar.bz2"))
- (sha256
- (base32
- "0mywq00xs0rvdp3kd7kmcv2brpzixz65ijzk2ahg7lh677k1yb80"))))
+ (name "xfce4-weather-plugin")
+ (version "0.11.3")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://gitlab.xfce.org/panel-plugins/"
+ name))
+ (commit (string-append name "-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1cxv5p1472vgy2nks9145m8yajsxrc1a83pmqpmnmvpyyandbdml"))))
(build-system gnu-build-system)
+ (arguments
+ (list #:configure-flags
+ #~(list "--enable-maintainer-mode"))) ;for weather-config_ui.h
(native-inputs
- (list intltool pkg-config))
+ (list xfce4-dev-tools))
(inputs
(list gtk+ json-c libsoup-minimal-2 libxfce4ui libxml2 xfce4-panel))
- (home-page
- "https://goodies.xfce.org/projects/panel-plugins/xfce4-weather-plugin")
+ (home-page "https://docs.xfce.org/panel-plugins/xfce4-weather-plugin/")
(synopsis "Show information about local weather in the Xfce panel")
(description "This Xfce panel plugin shows information about your
local weather in the panel, using forecast data provided by the