aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
author宋文武 <iyzsong@member.fsf.org>2024-12-31 14:32:42 +0800
committer宋文武 <iyzsong@member.fsf.org>2025-01-01 10:48:35 +0800
commit0b3ebac7aceb4722f333ea429e5ed5bea074eb97 (patch)
treedff6b4cfce443d341827a9b160465ed3fae92096
parent8183cf22bd1818c37cb793dc5738dc2ba560a35b (diff)
downloadguix-0b3ebac7aceb4722f333ea429e5ed5bea074eb97.tar.gz
guix-0b3ebac7aceb4722f333ea429e5ed5bea074eb97.zip
gnu: xfce4-wavelan-plugin: Update to 0.6.4.
* gnu/packages/xfce.scm (xfce4-wavelan-plugin): Update to 0.6.4. [source]: Switch to git-fetch. [native-inputs]: Add xfce4-dev-tools. [home-page]: Set to docs.xfce.org. Change-Id: Idc3e19f8c0f4b328096a1eebca0dd4272226376c
-rw-r--r--gnu/packages/xfce.scm28
1 files changed, 14 insertions, 14 deletions
diff --git a/gnu/packages/xfce.scm b/gnu/packages/xfce.scm
index 44d4adf556..d05c63be98 100644
--- a/gnu/packages/xfce.scm
+++ b/gnu/packages/xfce.scm
@@ -2255,24 +2255,24 @@ for the Xfce panel. It supports several features, such as:
(define-public xfce4-wavelan-plugin
(package
- (name "xfce4-wavelan-plugin")
- (version "0.6.3")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://archive.xfce.org/src/panel-plugins/"
- "xfce4-wavelan-plugin/"
- (version-major+minor version)
- "/xfce4-wavelan-plugin-" version ".tar.bz2"))
- (sha256
- (base32
- "0azpv0s3r4ag3gp0bsfvq0jgzycx6ivdsw5p0ga7425pdksw5h31"))))
+ (name "xfce4-wavelan-plugin")
+ (version "0.6.4")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://gitlab.xfce.org/panel-plugins/"
+ name))
+ (commit (string-append name "-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0hw1xglcq9niacmnb6masnx8b7vs0z38pbnbviy388mvj5bx54dm"))))
(build-system gnu-build-system)
(native-inputs
- (list intltool pkg-config))
+ (list xfce4-dev-tools))
(inputs
(list libxfce4ui xfce4-panel))
- (home-page
- "https://goodies.xfce.org/projects/panel-plugins/xfce4-wavelan-plugin")
+ (home-page "https://docs.xfce.org/panel-plugins/xfce4-wavelan-plugin/")
(synopsis "Show stats from WLAN interface in Xfce panel")
(description "This plugin is used to display stats from a wireless
lan interface (signal state, signal quality, network name (SSID)).")