aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-15 20:53:52 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:50 +0000
commitc91547093ca9eea09274838ee66e570371449e7e (patch)
tree2b12def835623a32cf48463ce774fb4daa934e78
parent57d3951381b3b1b60c15babaeb37133e9fe610b8 (diff)
downloadguix-c91547093ca9eea09274838ee66e570371449e7e.tar.gz
guix-c91547093ca9eea09274838ee66e570371449e7e.zip
gnu: Add go-github-com-dgryski-go-ddmin.
* gnu/packages/golang-check.scm (go-github-com-dgryski-go-ddmin): New variable. Change-Id: I8f5a15fb55c2166ee99b6099423c014860f8ee71
-rw-r--r--gnu/packages/golang-check.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/golang-check.scm b/gnu/packages/golang-check.scm
index 11a8e365f9..7f1c566982 100644
--- a/gnu/packages/golang-check.scm
+++ b/gnu/packages/golang-check.scm
@@ -219,6 +219,31 @@ style).
@end itemize")
(license license:isc)))
+(define-public go-github-com-dgryski-go-ddmin
+ (package
+ (name "go-github-com-dgryski-go-ddmin")
+ (version "0.0.0-20210904190556-96a6d69f1034")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/dgryski/go-ddmin")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0rgv4km7nffsjlyc4jkzy68mzhy38l7fdv7h5szv36wri7cx7n77"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/dgryski/go-ddmin"))
+ (home-page "https://github.com/dgryski/go-ddmin")
+ (synopsis "Delta-minimization algorithm in Golang")
+ (description
+ "Package ddmin implements the
+@url{https://users.cs.utah.edu/~regehr/papers/mintest.pdf, delta-minimization}
+test minimization algorithm.")
+ (license license:bsd-2)))
+
(define-public go-github-com-elgris-jsondiff
(package
(name "go-github-com-elgris-jsondiff")