aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSharlatan Hellseher <sharlatanus@gmail.com>2024-09-15 20:48:42 +0100
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-11-09 21:33:49 +0000
commit57d3951381b3b1b60c15babaeb37133e9fe610b8 (patch)
tree0c3181538dcaf5e58b944a5bfe3bb2c9b66e538e
parent46751aebc87b35eef9ccfe77ddcf85ff6cba494f (diff)
downloadguix-57d3951381b3b1b60c15babaeb37133e9fe610b8.tar.gz
guix-57d3951381b3b1b60c15babaeb37133e9fe610b8.zip
gnu: Add go-github-com-ryanuber-columnize.
* gnu/packages/golang-xyz.scm (go-github-com-ryanuber-columnize): New variable. Change-Id: I6cd3a54c445c312461e242ae221228993a24e0e6
-rw-r--r--gnu/packages/golang-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 7b7e83508c..c323a21a7e 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -6464,6 +6464,29 @@ Included are the following:
logging.")
(license license:expat)))
+(define-public go-github-com-ryanuber-columnize
+ (package
+ (name "go-github-com-ryanuber-columnize")
+ (version "2.1.2")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ryanuber/columnize")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0xxzzgvfabc2qx6n313vis8l4npkggiy5kjflv0arm2y7xnv73qj"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/ryanuber/columnize"))
+ (home-page "https://github.com/ryanuber/columnize")
+ (synopsis "Column formatted output for golang")
+ (description
+ "This package implements column-formatted output for Golang.")
+ (license license:expat)))
+
(define-public go-github-com-schollz-progressbar-v3
(package
(name "go-github-com-schollz-progressbar-v3")