aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrederick Muriuki Muriithi <fredmanglis@gmail.com>2025-02-12 11:28:47 -0600
committerSharlatan Hellseher <sharlatanus@gmail.com>2025-02-14 14:22:12 +0000
commitc83eede6073e9d99cd59fe16f055b2be1b795a7f (patch)
tree1d1e317e13d569da88d0a7243b6defb797d6edc9
parentc55d9aeb01e02df9afa45474a08a5898590ebbde (diff)
downloadguix-c83eede6073e9d99cd59fe16f055b2be1b795a7f.tar.gz
guix-c83eede6073e9d99cd59fe16f055b2be1b795a7f.zip
Add python-keithley2600
* gnu/packages/engineering.scm (python-keithley2600): New package. Change-Id: I6cca66222816730a04d3bd712cc6bbab4b42f327 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/engineering.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 965fe8839f..23b9bba83c 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -2771,6 +2771,39 @@ specification can be downloaded at @url{http://3mf.io/specification/}.")
(home-page "https://3mf.io/")
(license license:bsd-2)))
+(define-public python-keithley2600
+ (package
+ (name "python-keithley2600")
+ (version "2.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/OE-FET/keithley2600")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "19bs7lswb04a5xr4zdsknynmpllpj18nb19jcbjnzf1fs1dqg0hw"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list #:tests? #f)) ; no tests provided
+ (native-inputs
+ (list python-setuptools
+ python-wheel))
+ (propagated-inputs
+ (list python-numpy
+ python-pyvisa
+ python-pyvisa-py))
+ (home-page "https://keithley2600.readthedocs.io/en/stable/")
+ (synopsis "Full Python driver for Keithley 2600 series of SMU")
+ (description
+ "This package provides a full Python driver for the Keithley 2600B series
+of source measurement units. This driver provides access to base commands and
+higher level functions such as IV measurements, transfer and output curves,
+etc. Base commands replicate the functionality and syntax from the Keithley's
+internal TSP Lua functions.")
+ (license license:expat)))
+
(define-public python-pyvisa
(package
(name "python-pyvisa")