aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFrederick Muriuki Muriithi <fredmanglis@gmail.com>2025-02-12 11:28:46 -0600
committerSharlatan Hellseher <sharlatanus@gmail.com>2025-02-14 14:17:23 +0000
commitc55d9aeb01e02df9afa45474a08a5898590ebbde (patch)
tree1e196e4e245d89a8f2b3676a97c26fdcf8bc180e
parent6cfd4a42f6c5152a1489d4b30a1aa602864a517e (diff)
downloadguix-c55d9aeb01e02df9afa45474a08a5898590ebbde.tar.gz
guix-c55d9aeb01e02df9afa45474a08a5898590ebbde.zip
Add python-pyvisa-py
* gnu/packages/engineering.scm (python-pyvisa-py): New package. Change-Id: If6addef9392be03b53a5b4fac2f0fd752af5246f Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/engineering.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index bbb39a64df..965fe8839f 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -41,6 +41,7 @@
;;; Copyright © 2023 pinoaffe <pinoaffe@gmail.com>
;;; Copyright © 2024 Juliana Sims <juli@incana.org>
;;; Copyright © 2024 Nguyễn Gia Phong <mcsinyx@disroot.org>
+;;; Copyright © 2025 Frederick Muriuki Muriithi <fredmanglis@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -2810,6 +2811,32 @@ specification can be downloaded at @url{http://3mf.io/specification/}.")
measurement devices and test equipment via GPIB, RS232, Ethernet or USB.")
(license license:expat)))
+(define-public python-pyvisa-py
+ (package
+ (name "python-pyvisa-py")
+ (version "0.7.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "PyVISA-py" version))
+ (sha256
+ (base32 "0lg8a041yg4yl31bxyyy51nh92rdp8ps94pzpyz7siaqg235npsc"))))
+ (build-system pyproject-build-system)
+ (native-inputs
+ (list python-pytest
+ python-wheel
+ python-setuptools))
+ (propagated-inputs
+ (list python-pyvisa
+ python-typing-extensions))
+ (home-page "https://pyvisa-py.readthedocs.io/")
+ (synopsis "Backend for PyVISA")
+ (description
+ "PyVISA-py is a backend for PyVISA that implements most of the methods
+for Message Based communication (Serial/USB/GPIB/Ethernet) using Python and
+some well developed, easy to deploy and cross platform libraries.")
+ (license license:expat)))
+
(define-public python-pandapower
(package
(name "python-pandapower")