aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2024-06-01 16:57:58 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:28:43 +0000
commitc7505f46587051aa931ffbd69bf1183fca066687 (patch)
treebd68bf0de74e20145df4d9967351385fcb8f6fc3
parente07ea90b6d63a99c366c0262007e5f1c57dda4a9 (diff)
downloadguix-c7505f46587051aa931ffbd69bf1183fca066687.tar.gz
guix-c7505f46587051aa931ffbd69bf1183fca066687.zip
gnu: python-identify: Update to 2.5.36.
* gnu/packages/python-xyz.scm (python-identify): Update to 2.5.36. [build-system]: Use pyproject-build-system. [arguments]: Use G-Expressions. Do not override the check phase. [native-inputs]: Add python-ukkonen. Change-Id: I970507dc358029b4e2cc0a295d19db4b28202544 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/python-xyz.scm21
1 files changed, 9 insertions, 12 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index ec1eb1f9a4..7aa0f89e20 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -28571,7 +28571,7 @@ distance (Ukkonen).")
(define-public python-identify
(package
(name "python-identify")
- (version "1.4.25")
+ (version "2.5.36")
(source
(origin
;; There are no tests in the PyPI tarball.
@@ -28581,19 +28581,16 @@ distance (Ukkonen).")
(commit (string-append "v" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "1fqgci6skckcq0x5pnxh6k2qjzn1ndsrgha1j6wwv1ld4g9bd3hz"))))
- (build-system python-build-system)
+ (base32 "1il0d1zh31jx36m0lvhpiykx95i95dcfrgrfbz2x6la884zsmvq8"))))
+ (build-system pyproject-build-system)
(arguments
- `(#:phases
- (modify-phases %standard-phases
- ;; system-error "utime" "~A" ("No such file or directory")
- (delete 'ensure-no-mtimes-pre-1980)
- (replace 'check
- (lambda* (#:key tests? #:allow-other-keys)
- (when tests?
- (invoke "pytest" "-vv")))))))
+ (list
+ #:phases #~(modify-phases %standard-phases
+ ;; system-error "utime" "~A" ("No such file or directory")
+ (delete 'ensure-no-mtimes-pre-1980))))
(native-inputs
- (list python-coverage python-pytest python-setuptools python-wheel))
+ (list python-coverage python-pytest python-setuptools
+ python-ukkonen python-wheel))
(propagated-inputs
(list python-editdistance))
(home-page "https://github.com/chriskuehl/identify")