aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVinicius Monego <monego@posteo.net>2024-06-01 16:57:57 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:28:43 +0000
commite07ea90b6d63a99c366c0262007e5f1c57dda4a9 (patch)
tree4277b22a663de58f45ca82bb88be2b9ffcc823af
parent3d4423c0ce2e9d809ed6c88caed23aad4c66ca77 (diff)
downloadguix-e07ea90b6d63a99c366c0262007e5f1c57dda4a9.tar.gz
guix-e07ea90b6d63a99c366c0262007e5f1c57dda4a9.zip
gnu: Add python-ukkonen.
* gnu/packages/python-xyz.scm (python-ukkonen): New variable. Change-Id: I826b003f1c22e5bf28829d9f2adc5f467d17ed45 Signed-off-by: Sharlatan Hellseher <sharlatanus@gmail.com>
-rw-r--r--gnu/packages/python-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index eb68d6215e..ec1eb1f9a4 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -28545,6 +28545,29 @@ and corruption checks.")
library to allow local file system access via @code{file://} URLs.")
(license license:asl2.0)))
+(define-public python-ukkonen
+ (package
+ (name "python-ukkonen")
+ (version "1.0.1")
+ (source
+ (origin
+ ;; There are no tests in the PyPI tarball.
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/asottile/ukkonen")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "17gspl2dsykg000275svvyam4k7wz9ypi9xrfrmsgcgryczravlc"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-pytest))
+ (propagated-inputs (list python-cffi))
+ (home-page "https://github.com/asottile/ukkonen")
+ (synopsis "Implementation of bounded Levenshtein distance (Ukkonen)")
+ (description "This package is an implementation of of bounded Levenshtein
+distance (Ukkonen).")
+ (license license:expat)))
+
(define-public python-identify
(package
(name "python-identify")