aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 21:29:09 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:37 +0200
commitc5cfdf215d2d8412f595ee93b0b25147b9361147 (patch)
treecee869e72c20ba4d550b68d672c2f215d7577f46
parent9a33ab9fecf7d3894d41a936694d7145d5f1b06e (diff)
downloadguix-c5cfdf215d2d8412f595ee93b0b25147b9361147.tar.gz
guix-c5cfdf215d2d8412f595ee93b0b25147b9361147.zip
gnu: texlive-beamer: Refresh package definition.
* gnu/packages/tex.scm (texlive-beamer): Remove SIMPLE-TEXLIVE-PACKAGE call. [propagated-inputs]: Add TEXLIVE-AMSFONTS, TEXLIVE-AMSMATH, TEXLIVE-ATBEGSHI, TEXLIVE-ETOOLBOX, TEXLIVE-GRAPHICS, TEXLIVE-HYPERREF, TEXLIVE-IFTEX, TEXLIVE-OBERDIEK, TEXLIVE-PGF, TEXLIVE-TOOLS, TEXLIVE-TRANSLATOR, TEXLIVE-UCS, TEXLIVE-XCOLOR.
-rw-r--r--gnu/packages/tex.scm35
1 files changed, 25 insertions, 10 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 86ac27fbf3..e390466287 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -10337,19 +10337,34 @@ for a wealth of support information.")
(define-public texlive-beamer
(package
- (inherit (simple-texlive-package
- "texlive-beamer"
- (list "/doc/latex/beamer/"
- "/tex/latex/beamer/")
- (base32
- "091n27n4l3iac911bvmpp735ffryyzaq46mkclgn3q9jsvc4ngiv")
- #:trivial? #t))
+ (name "texlive-beamer")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/latex/beamer/"
+ "tex/latex/beamer/")
+ (base32
+ "091n27n4l3iac911bvmpp735ffryyzaq46mkclgn3q9jsvc4ngiv")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
(propagated-inputs
- (list texlive-hyperref texlive-oberdiek texlive-etoolbox
- texlive-pgf))
+ (list texlive-amsfonts
+ texlive-amsmath
+ texlive-atbegshi
+ texlive-etoolbox
+ texlive-graphics
+ texlive-hyperref
+ texlive-iftex
+ texlive-oberdiek
+ texlive-pgf
+ texlive-tools
+ texlive-translator
+ texlive-ucs
+ texlive-xcolor))
(home-page "https://www.ctan.org/pkg/beamer")
(synopsis "LaTeX class for producing presentations and slides")
- (description "The beamer LaTeX class can be used for producing slides.
+ (description
+ "The @code{beamer} LaTeX class can be used for producing slides.
The class works in both PostScript and direct PDF output modes, using the
@code{pgf} graphics system for visual effects. Content is created in the
@code{frame} environment, and each frame can be made up of a number of slides