aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2023-05-15 21:20:42 +0200
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2023-07-18 18:11:36 +0200
commit9a33ab9fecf7d3894d41a936694d7145d5f1b06e (patch)
tree6689399a4a4c196c135f0b1f34c9146e0d309880
parente92dc9384ffb8384d23a90e04f1655d18036cf45 (diff)
downloadguix-9a33ab9fecf7d3894d41a936694d7145d5f1b06e.tar.gz
guix-9a33ab9fecf7d3894d41a936694d7145d5f1b06e.zip
gnu: texlive-pstricks: Refresh package definition.
* gnu/packages/tex.scm (texlive-pstricks): Remove SIMPLE-TEXLIVE-PACKAGE call. [propagated-inputs]: Add TEXLIVE-AMSFONTS, TEXLIVE-AMSMATH, TEXLIVE-BABEL, TEXLIVE-BERA, TEXLIVE-BIBLATEX, TEXLIVE-BOOKTABS, TEXLIVE-CAPTION, TEXLIVE-CHNGCNTR, TEXLIVE-ESO-PIC, TEXLIVE-FANCYVRB, TEXLIVE-FILECONTENTS, TEXLIVE-FOOTMISC, TEXLIVE-GRAPHICS, TEXLIVE-HYPERREF, TEXLIVE-IFPLATFORM, TEXLIVE-IFTEX, TEXLIVE-LISTINGS, TEXLIVE-MULTIDO, TEXLIVE-RAGGED2E, TEXLIVE-SETSPACE, TEXLIVE-SUBFIG, TEXLIVE-TOOLS, TEXLIVE-XCOLOR.
-rw-r--r--gnu/packages/tex.scm74
1 files changed, 48 insertions, 26 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 318d397f68..86ac27fbf3 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -10464,32 +10464,54 @@ change.")
(license license:lppl1.3+)))
(define-public texlive-pstricks
- (let ((template (simple-texlive-package
- "texlive-pstricks"
- (list "/doc/generic/pstricks/"
- "/dvips/pstricks/"
- "/tex/generic/pstricks/"
- "/tex/latex/pstricks/")
- (base32
- "15c9iqfq2y9c8c78cvqb6vzd5a5rm7qq5x7m05jq1hb8sgqrqb0j")
- #:trivial? #t)))
- (package
- (inherit template)
- (arguments
- (substitute-keyword-arguments (package-arguments template)
- ((#:phases phases)
- `(modify-phases ,phases
- (delete 'reset-gzip-timestamps)))))
- (home-page "http://www.ctan.org/pkg/pstricks")
- (synopsis "PostScript macros for TeX")
- (description "PSTricks offers an extensive collection of macros for
-generating PostScript that is usable with most TeX macro formats, including
-Plain TeX, LaTeX, AMS-TeX, and AMS-LaTeX. Included are macros for colour,
-graphics, pie charts, rotation, trees and overlays. It has many special
-features, including a wide variety of graphics (picture drawing) macros, with
-a flexible interface and with colour support. There are macros for colouring
-or shading the cells of tables.")
- (license license:lppl1.3+))))
+ (package
+ (name "texlive-pstricks")
+ (version (number->string %texlive-revision))
+ (source (texlive-origin
+ name version
+ (list "doc/generic/pstricks/"
+ "dvips/pstricks/"
+ "tex/generic/pstricks/"
+ "tex/latex/pstricks/")
+ (base32
+ "15c9iqfq2y9c8c78cvqb6vzd5a5rm7qq5x7m05jq1hb8sgqrqb0j")))
+ (outputs '("out" "doc"))
+ (build-system texlive-build-system)
+ (propagated-inputs
+ (list texlive-amsfonts
+ texlive-amsmath
+ texlive-babel
+ texlive-bera
+ texlive-biblatex
+ texlive-booktabs
+ texlive-caption
+ texlive-chngcntr
+ texlive-eso-pic
+ texlive-fancyvrb
+ texlive-filecontents
+ texlive-footmisc
+ texlive-graphics
+ texlive-hyperref
+ texlive-ifplatform
+ texlive-iftex
+ texlive-listings
+ texlive-multido
+ texlive-ragged2e
+ texlive-setspace
+ texlive-subfig
+ texlive-tools
+ texlive-xcolor))
+ (home-page "http://www.ctan.org/pkg/pstricks")
+ (synopsis "PostScript macros for TeX")
+ (description
+ "PSTricks offers an extensive collection of macros for generating
+PostScript that is usable with most TeX macro formats, including Plain TeX,
+LaTeX, AMS-TeX, and AMS-LaTeX. Included are macros for colour, graphics, pie
+charts, rotation, trees and overlays. It has many special features, including
+a wide variety of graphics (picture drawing) macros, with a flexible interface
+and with colour support. There are macros for colouring or shading the cells
+of tables.")
+ (license license:lppl1.3+)))
(define-public texlive-pst-text
(package