aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-10 00:53:59 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:55 +0000
commitbf1fd06d4f5b53b943c6565acaf3061041ef6c81 (patch)
tree9a5c1bf9f96fdb0f504901e511283a58aeef3a63
parentc816bf49164fdddce686ca461ee5336a2cac7b33 (diff)
downloadguix-bf1fd06d4f5b53b943c6565acaf3061041ef6c81.tar.gz
guix-bf1fd06d4f5b53b943c6565acaf3061041ef6c81.zip
gnu: python-autoflake: Update to 2.3.1.
* gnu/packages/python-xyz.scm (python-autoflake): Update to 2.3.1. [build-system]: Move to pyproject-build-system. [arguments]<#:phases>: Add check phase replacement. [native-inputs]: Add python-hatchling. Change-Id: I0421107a98b1181a76e1874f23e6aa6e7709e434 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/python-xyz.scm15
1 files changed, 12 insertions, 3 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index fe89f5eb0f..ebfa9d75a8 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -15399,14 +15399,23 @@ directives.")
(define-public python-autoflake
(package
(name "python-autoflake")
- (version "1.3.1")
+ (version "2.3.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "autoflake" version))
(sha256
- (base32 "0nzr057dbmgprp4a52ymafdkdd5zp2wcqf42913xc7hhvvdbj338"))))
- (build-system python-build-system)
+ (base32 "17lhrmz6h7pz2nald90p8gn3hhzbqwmd78819yf4b1habgf7b2y9"))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda _
+ (invoke "python" "test_autoflake.py"))))))
+ (native-inputs
+ (list python-hatchling))
(propagated-inputs
(list python-pyflakes))
(home-page "https://github.com/myint/autoflake")