aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNicolas Graves <ngraves@ngraves.fr>2024-05-10 00:53:58 +0200
committerSharlatan Hellseher <sharlatanus@gmail.com>2024-12-13 20:18:55 +0000
commitc816bf49164fdddce686ca461ee5336a2cac7b33 (patch)
treec98de47f79500b9bf19537f0f607efffab13c9ca
parentcf1ea97b69f0181a47fb3344b836349415597f86 (diff)
downloadguix-c816bf49164fdddce686ca461ee5336a2cac7b33.tar.gz
guix-c816bf49164fdddce686ca461ee5336a2cac7b33.zip
gnu: python-apprise: Improve package style.
* gnu/packages/python-xyz.scm (python-apprise): [arguments]: Convert <#:phases> check replacement into <#:test-flags>. Change-Id: I85c2ebadf65a4f1a7735042e784e56313c3de539 Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr>
-rw-r--r--gnu/packages/python-xyz.scm19
1 files changed, 7 insertions, 12 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 3f066f78a5..fe89f5eb0f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -320,6 +320,13 @@
(sha256
(base32 "0wvs1k71fipn617y9wsdcvwcgg2pd0nvriarlwl4438la4086ppg"))))
(build-system pyproject-build-system)
+ (arguments
+ (list
+ #:test-flags
+ #~(list "--numprocesses" "auto"
+ "--ignore=test/test_plugin_macosx.py"
+ "-k" (string-append "not test_plugin_mqtt_tls_connect_success"
+ " and not test_plugin_mqtt_tls_no_verify_success"))))
(propagated-inputs (list python-certifi
python-click
python-dataclasses
@@ -336,18 +343,6 @@
python-pytest-mock
python-pytest-xdist
python-wheel))
- (arguments
- (list
- #:phases
- #~(modify-phases %standard-phases
- (replace 'check
- (lambda* (#:key tests? inputs outputs #:allow-other-keys)
- (when tests?
- (delete-file "test/test_plugin_macosx.py")
- (invoke "pytest" "-vv" "-k"
- (string-append
- "not test_plugin_mqtt_tls_connect_success"
- " and not test_plugin_mqtt_tls_no_verify_success"))))))))
(home-page "https://github.com/caronc/apprise")
(synopsis
"Push notification Python library that works with many platforms")